Основы Blender v.2.42a - перевод учебника - BlenderУкраина - blender3d.org.ua

Основы Blender v.2.42a - offline версия
Посетите сайт BlenderУкраина (русскоязычный ресурс о Blender) в интернете по адресу blender3d.org.ua - Плагины, Модели, Туториалы, Форум - Все о Blender3d по русски.

Основы Blender v.2.42a (второе издание)
автор James Chronister
перевод Юлии Корбут
Оглавление:
• Вступление - о программе Blender
• Основные понятия Рендера и Анимации
• Основные Опции и "Горячие Клавиши"
Глава 1 - Интерфейс Blender
• Экран Blender'a
• Типы Окон
• Открытие, Сохранение и Прикрепление Файлов
• Упаковка Данных
• Импорт Объектов (из других форматов файлов)

Глава 2 - Работа с Окнами Видов
• Создание Окна Вида
• Изменение Оконного Типа
• Передвижение по 3D пространству
• Направления Просмотра * практическое задание

Глава 3 - Создание и Редактирование Объектов
• Работа с основными Меш-объектами(mesh)
• Использование Главных Модификаторов для Манипуляции Меш-Объектами
• Создание Объектов * практическое задание
• Режим Редактирования - Редактирование Вершин Меш-Объекта
• Режим Пропорционального Редактирования Вершин
• Базовое Редактирование * практическое задание
• Объединение/Разделение Меш-Объектов, Булевы Операции
• Булевы Операции * практическое задание

Глава 4 - Лампы и камеры
• Типы Ламп, а так же их Настройки
• Опции и Настройки Камеры
• Освещение и Камера * практическое задание

Глава 5 - Материалы и Текстуры
• Основные Настройки Материала
• Настройки Hallo (Ореол)
• Применение Материалов * практическое задание
• Основные Настройки Текстуры
• Использование Jpeg изображения в качестве Текстуры
• Карта Смещения
• Применение Текстур * практическое задание

Глава 6 - Настройки Окружения
• Использование Цвета, Звезд и Тумана
• Создание 3D Фона Облаков
• Использование Изображения в качестве Фона
• Добавление Окружения * практическое задание

Глава 7 - Настройки Окна Рендера
• Основные Опции, Рендер Jpg изображения
• Создание AVI Видео Файла
• Рендер Изображения * практическое задание

Глава 8 - Трассировка Лучей (зеркальное отображение, прозрачность, тень)
• Освещение и Тени
• Рефлекторность(зеркальное отражение) и Преломление(прозрачность)
• Трассировка Лучей * практическое задание

Глава 9 - Основы Анимации
• Синхронность, Движение, Вращение и Масштабирование
• Работа с Окном IPO
• Автоматическое Закрепление Кадра (Keyframing)
• Анимирование Материалов, Ламп и Настроек Окружения
• Создание Анимации * практическое задание

Глава 10 - Добавление 3D Текста
• Настройки 3D Текста в Blender
• Деформация текста с помощью Кривой
• Использование программы Elefont для 3D Текста
• Создание 3D Текста * практическое задание

Глава 11 - Основы NURBS и Метa-Поверхностей
• Использование NURBS для создания изогнутых поверхностей
• Эффект Жидкости и капель с использованием Метa-Поверхностей
• Мета-Поверхности * практическое задание

Глава 12 - Модификаторы
• Subsurf (сглаживание меш-объекта)
• Эффект Построения
• Зеркальное отображение меш-объектов
• Эффект Волны
• Булевые Операции (добавление и вычисление)
• Использование Модификаторов * практическое задание

Глава 13 - Система Частиц и их Взаимодействие
• Настройка частиц
• Влияние Материала на Систему Частиц
• Взаимодействие частиц с объектами
• Образцы Настроек Частиц
• Система Частиц * практическое задание

Глава 14 - Связывание Объектов Методом Родитель-Потомок
• Связь между объектами
• Регулировка Центров Объектов (точек вращения)
• Создание Механических Суставов * практическое задание

Глава 15 - Работа с Ограничителями
• Слежение за объектом
• Слежение Камеры * практическое задание
• Путь Следования и Кривые
• Использование Кривых для создания Поверхности объекта
• Кривая и Путь * практическое задание

Глава 16 - Арматуры (кости и скелет)
• Использование арматуры для деформирования меш-объекта
• Создание Групп Вершин
• Использование IK(Inverse Kinomatics)
• Создание Скелета * практическое задание

Глава 17 - Относительные Ключи Вершин
• Создание Относительных Ключей Вершин
• Использование Слайдеров Редактора Действий
• Новая Панель Создания ОКВ(RVK) в Blender 2.40
• Относительные Ключи Вершин * практическое задание

Глава 18 - Система мягких тел (Soft Bodies)
• Создание ткани и эффекта волны
• Использование Сил для манипуляции мягкими телами
• Создание Флага * практическое задание

Глава 19 - Создание Пружин, Резьбы и Шестеренок
• Дублирование Меш-объектов для создания Пружин и Резьбы
• Создаем спиральную Поверхность
• Моделирование Шестеренок * практическое задание

Глава 20 - Основы Игрового Движка -Game Engine (анимация в реальном времени)
• Настройка Physics Engine
• Использование Логических Блоков
• Применение Материалов
• Использование Physics Engine в анимации
• Анимация Реального Времени * практическое задание

Глава 21 - Редактор Видео Последовательностей
• Создание фильма из отдельных клипов
• Добавление Аудио Дорожки
• Создание Фильма * практическое задание
© 2004, 2006 Второе издание, автора Джеймса Кронистера. Этот документ может быть воспроизведен целиком или частично без разрешения автора. Не стесняйтесь использовать это руководство для любых образовательных приложений. Мне нравится получать письма от других преподователей и поэтому, пожалуйста, дайте мне знать, каким образом вы используете эту книгу. Вы не можете использовать этот учебник с любым программным обеспечением и документацией, предназначенных для коммерческого применения (продажи, прибыли), не спросив письменного разрешения автора. С вопросами и замечаниями можно обращаться по электронной почте: jchronister<@>cdschools.org. Данный документ и другая информация может быть найдена на сайте www.cdschools.org или www.technology-education.org. Информацию о программе Blender можно найти на сайте www.blender.org. Пользователи Blender могут также найти информацию о том, как пользоваться этой программой на www.blenderartists.org

Вверх страницы
© 2007 Юлия Корбут некоторые права соблюдены. По любым вопросам о материалах сайта, а также по вопросам о правах на материалы обращайтесь:
© 2007 Julia Korbut some rights reserved. With any legal questions feel free to contact me:


назад Основы Blender v.2.42a вперед

Вступление

О Blender

Как Blender может быть свободно-распространяемым?

У людей, как правило, бесплатное программное обеспечение ассоциируется с терминами "плохое", "с ограниченными возможностями" или с "демо версиями". Blender же является полностью функциональным. Он разрабатывается сообществом разработчиков open-source, где люди со всего мира вносят свой вклад в его развитие. Blender является средой разработки рендеринга\анимации\игр, программа с открытым исходным кодом, свободно распространяемая и поддерживаемая Blender Foundation, вы можете скачать Blender бесплатно с сайта www.blender.org.

Основная цель Blender Foundation, была найти способ продолжить разработку и продвижение Blender'а как общественнооснованый проект с открытыми исходниками - Open Source. В Июле 2002, Тон сумел получить согласие инвесторов NaN на уникальный план Blender Foundation, делающий Blender как opensource продукт. Кампании "Free Blender", необходимо было собрать 100,000 EUR, чтобы Foundation смогла выкупить права на исходники Blender'а и интеллектуальную собственность у инвесторов NaN и в последствии выпустить Blender как opensource продукт. С полной энтузиазма группой добровольцев, некоторые из них бывшие сотрудники NaN, кампания по сбору средств была запущена. К всеобщему удивлению и восхищению, кампания собрала необходимую сумму 100,000 EUR за семь недель. В Воскресение 13 Октября 2002, Blender был представлен миру под лицензией GNU General Public License (GPL)- Основная Общественная Лицензия. Разработка Blender'а продолжается и по сей день, командой волонтеров со всего мира, под руководством первоначального создателя Blender'а - Тона Розендала.

Blender может стать довольно сложной в изучении программой, если пытаться освоить все его многочисленные возможности. Эта книга разработана для того, что бы вы могли хорошо освоить основные методы создания объектов, сцен, а так же анимации. Лучший совет, который я могу дать при изучении этой программы, - Не бросайте изучение! Любая программа рендеринга и анимации имеет сложный процесс изучения и Blender в этом смысле тоже не исключение. После нескольких недель обучения, многие вещи становятся легче. Эта обучающая программа была разработана для ежедневного изучения в сочетании с упражнениями. Из-за этого, некоторые возможности Blender не были описаны так всеобъемлюще, как могли бы. Если Вы используете эту книгу для самостоятельного изучения или же в качестве инструмента самоусовершенствования - Вам необходимо найти дополнительную информацию на таких уважаемых сайтах как www.blender.org и www.elysiun.com. На этих сайтах вы найдете туториалы и форумы, где вам смогут помочь в некоторых вопросах. Тысячи пользователей Блендера во всем мире, просматривают эти форумы, чтобы дать или получить совет. Воспользуйтесь этой обширной базой знаний!

Информация о Версии: текущая версия во время издания этой книги 2.42a.

назад | Основы Blender v.2.42a | вперед
назад | Оглавление | вперед


Основные понятия Рендера и Анимации

Рендеринг

Рендер является графическим отображением 3D сцены или объекта. Доступны такие особенности как материалы, освещение, тени, дополнительные эффекты и качество рендера. Чем больше этих элементов вы добавляете, тем более реалистичной становится ваша сцена, но это так же увеличивает время для отображения вашего изображения.

Материалы и Текстуры:

С помощью них Вы можете добавлять объекту цвет и текстурность. Материалы добавляют объекту реализм с помощью различных эффектов. Вы можете контролировать блеск (specularity), характер светового излучения, прозрачность, а так же повторение образца материала. Текстуры могут быть сделаны из любой отсканированной фотографии. Для Blender в качестве текстуры могут использоваться файлы .Jpg или .Bmp. Лучше всего использовать квадратные изображения, базирующиеся от размера 8х8 пикселей(16х16, 64х64, 256х256), однако прямоугольные изображения так же можно применять. Многопиксельное изображение дает более качественную текстуру, но размер файла так же увеличивается. Поскольку Blender развивается, он работает с прямоугольными изображениями теперь так же хорошо как с квадратными, но все же было бы хорошо следовать старым правилам.

Освещение:

Лампы добавляют реализм вашей сцене, с помощью рефлекторности и теней. Вы можете контролировать тип, интенсивность, а так же цвет освещения. Некоторые лампы могут дать сделать эффект "тумана" или "пыли". Освещение может быть "ореольным" или "объемный". Так же вы сможете настроить дистанцию иллюминации.

Камеры:

Камера - это ваша точка видения сцены. Вы можете контролировать ее как настоящую камеру: управлять длиной линзы, чтобы увидеть объект крупным планом или под определенным углом. Так же можно настраивать область обзора камеры.

Анимация:

Анимация - это серия отрендеренных изображений, сформированных в фильм. На качество вашего фильма влияют все выше перечисленные пункты, включая частоту кадров в секунду (FPS), размер, а так же тип файла, сжатие. Наиболее распространенный метод анимации называется keyframing. Ключевые кадры создаются в различные моменты анимации, а потом компьютер делает все остальные, переходные кадры между этими ключами. Основные варианты анимации включают изменение размера, вращение и передвижение объектов.

Фактор времени

Перед тем как сделать анимацию, необходимо установить длину вашей анимации в кадрах, а так же количество кадров в секунду (fps).Расчитать длину анимации можно по этим значениям.

Опции Частоты Кадров(fps):

NTSC - США и Япония видео стандарт 30 fps
Film - Кин-стандарт 24 fps
PAL - Европейский видео стандарт 25 fps
Custom - Ваша собственная настройка fps

* Мы обычно используем частоту кадров 25-30 fps, в зависимости от быстродействия компьютера или когда мы хотим сохранить анимацию на DVD. Для того, что бы использовать 25-30 fps - нажмите на кнопку "PAL" или NTSC.

Создание Ключевых Кадров Анимации:

Ключевые кадры устанавливаются в начале и в конце желаемого передвижения, вращения или изменения размера объекта. Подумайте, с какой скоростью должен передвигаться(изменятся в размере, вращаться) ваш объект, относительно кадров в секунду. Так, например, если вы хотите передвинуть объект из пункта А в пункт B за 2 секунды и у вас частота кадров равна 15, установите на 30 кадров анимации - 2 Ключевых Кадра.

Следование по Пути и Слежение за Объектами:

В большинстве анимационных программ, камера во время движения может следовать по определенному пути, либо следить за объектом (или и то и другое). Эта возможность экономит много времени и количество необходимых Ключевых Кадров для анимации уменьшается.

Опции Вывода:

Мы обычно сохраняем наши видео в AVI формате, для Windows. Этот формат легко проигрывают большинство медиа-плееров. Агенты сжатия, позволяют нам управлять размером файла в известной степени. Однако, анимации могут быть довольно большого размера и занять до нескольких сотен мегабайтов дискового пространства. Агент сжатия, который я нашел, для работы с большинством компьютеров, является Indeo 5.1. Для хорошего размера анимации, я обычно использую разрешение 640 x 480 пикселов. Это считается низким разрешением для компьютеров и качественным разрешением при полноэкранном проигрывании.

Анимация Реального Времени(только для Blender):

Анимация в Реальном Времени позволяет Вам добавлять к вашим объектам физические свойства, а так же использовать клавиатуру и другие особенности, чтобы управлять ими. Вы можете создать действующих лиц, изменять массу, контролировать скольжение (трение), настраивать силу и вращение в х, у, и z плоскостях, создавать связи с другими объектами в сцене. Со временем, возможно будут созданы интересные трехмерные игры и прогулки по архитектурным строениям в реальном времени.

Текущая версия Blender является первой версией, в которой Вы можете использовать физику движения для создания управляемой анимацией. Теперь вы можете использовать физику Blender для создания реалистичной анимации падения, вращения и т.д., а после использовать их в Ваших роликах.


Основные Опции и "Горячие Клавиши"

Основные Команды Blender

Это неполный список команд Blender. Посетите сайт Blender.org для получения более подробного списка.

Клавиша [TAB] - Переключение между Режимом Редактирования (редактирование вершин) и Объектным режимом. Если Вы находитесь в Режиме редактирования объекта и создаете новый объект - он будет объединен с этим объектом.

Клавиша "O" - Клавиша "O"(не ноль) запускает Режим Пропорционального редактирования вершин, пока вы находитесь в Режиме Редактирования.

Клавиша "A" - В Режиме Редактирования эта опция используется для выделения всех вершин, повторное нажатие этой кнопки приведет к снятию выбора с вершин.

Клавиша "B" - Вызывает инструмент "Выделения Прямоугольником", используется для выделения нескольких объектов. Режиме Редактирования с помощью этого инструмента можно выделять несколько вершин. Повторное нажатие Клавиши "B" - вызывает инструмент "Выделение Кругом", радиус которого вы можете изменять с помощью скрола мышки.

[Space Bar] - Вызывает Меню Инструментов, в котором вы можете выбрать добавление меш-объекта, камеры, лампы и т.д.

[NumPad] - Управление режимами просмотра: "7" - Вид сверху, "1" - Вид спереди, "3" - Вид с боку, "0" - Вид из камеры, "5" - перспектива, "." - изменение фокусного расстояния, относительно выбранного объекта, "+" и "-" - изменение фокусного расстояния в большую и меньшую сторону соответственно.

Мышка - Левая клавиша предназначена для манипулирования, правая для выделения, средняя для вращения просмотра и изменение фокусного расстояния. Если Вы будете удерживать Shift и одновременно среднюю среднюю клавишу мышки - то Вы сможете двигая мышкой передвигать 3d проекцию экрана.

Клавиша "Shift" - Удерживайте "Shift", что бы делать множественное выделение правой клавишей мышки.

Клавиши "Стрелки" - Используются для установки кадров анимации. Правая стрелка увеличивает количество кадров на 1, Левая уменьшает на 1 кадр, Стрелка вверх - увеличивает количество кадров на 10, а Стрелка вниз - уменьшает на 10.

Клавиша "R" - Вращение выделенных объектов или вершин.

Клавиша "S" - Масштабирование выделенных объектов или вершин.

Клавиша "G" - Перемещение выделенных объектов или вершин.

Клавиша "P" - Если Вы находитесь в Режиме Редактирования - Вы можете нажатием Клавиши "P" отделить выделенные вершины в отдельный меш-объект.

Комбинация [Shift D] - Дублирование или копирование выделенных объектов или вершин.

Клавиша "E" - Находясь в Режиме Редактирования, Вы можете экструдировать (вытянуть) выделенные вершины.

Клавиша "U" - В Объектном Режиме вызывает меню Единого Использования, вы можете его использовать, что бы сделать уникальным Материал, Анимацию(IPO) и т.д. В Режиме Редактирования работает как "Отменить команду", с помощью этой "горячей клавиши" вы можете вернуться на несколько шагов назад. К сожалению пока эта опция не позволяет отменить все команды.

Клавиша "M" - В Объектном Режиме Перемещает выбранные объекты на другой слой. В Режиме Редактирования работает как инструмент зеркального отображения объекта.

Клавиша "Z" - Переключение "каркасного" отображения в "заполненное" отображение объекта.

Комбинация [Alt Z] - Переключение "заполненного" отображения в "затемненное" отображение объекта.

Клавиша "P" - В Объектном Режиме запускает Режим Игры.

Комбинация [Alt/Ctrl + "P"] - Используется для того что бы создать (либо разорвать) связь между объектами типа "Родитель-Потомок". Для создания связи, удерживая Shift выберите объект, который будет "Потомком" первым, а затем объект, который будет "Родитель". Нажмите [Ctrl P]. Для разрыва связи, выполните ту же процедуру, но в конце нажмите вместо [Ctrl P] - [Alt P].

Клавиша "N" - Вызывает Информационное Окно выделенного объекта. Данные в этом окне можно изменять.

Комбинация [Ctrl J] - Служит для объединения выбранных объектов в одно целое.

Комбинация [Alt A] - Проигрывает анимацию в выбранном окне. Ваш курсор должен находиться в этом окне для начала проигрывания.

Клавиша "F" - Создает грань между выделенными вершинами в Режиме Редактирования. Для создание грани допустимо выделение только 3 или 4 вершин.

Клавиша "W" - В Режиме Редактирования вызывает "специальное" меню. В Объектном Режиме вызывает меню Булевых Операций.

Клавиша "X" или Delete - Удаляет выбранный объект, вершины или грани.

Функциональные Клавиши:

F1 - Загрузка файла; F2- Сохранение файла; F3 - Сохранение картинки; F4 - Кнопки Редактирования Ламп; F5 - Кнопки Редактирования Материалов; F6 - Кнопки редактирования Текстур; F7 - Кнопки Анимации; F8 - Кнопки Анимации Реального Времени; F9 - Кнопки Редактирования; F10 - Кнопки Дисплея; F11 - Последний Рендер; F12 - Рендер.

Клавиша "I" - Используется для вставки Ключевого Кадра анимации. Объекты могут быть анимированные с помощью основных инструментов Вращения, Перемещения и Изменения Размера, а тк же их всевозможных комбинаций.

Комбинация [Alt U] - Это новинка в Блендере. Опция глобальной отмены команды. Нажав [Alt U] вы увидите список команд, которые можно отменить. По умолчанию количество шагов отмены 32, но вы можете изменить это значение в Пользовательской Панели Настроек, находящейся в самом верхнем окне экрана.

Комбинация [Alt C] - Используется для того, что бы конвертировать меш-объекты, текст и кривые. Например, если вы создали текст и хотите его преобразовать в меш-объект, с помощью Alt C - вы сможете конвертировать его в кривую, повторное нажатие Alt C превратит кривую в меш-объект.

Комбинация [Shift Space] - Делает активное окно полноэкранным(fullscreen).

Комбинация [Ctrl 0] - Очень удобная опция, если вы используете в вашей сцене несколько камер. Выделите одну из камер затем нажмите [Ctrl 0(ноль)] и эта камера станет главной.

Базовая Панель Кнопок:


Глава 1: Интерфейс Blender

Экран Blender'a

Когда я впервые увидел Blender и прочитал несколько уроков я думал, что все это будет легко и интересно. Но после того как я впервые попробовал сделать что-либо в этой программе - я решил навсегда забыть о ней, потому что у меня ничего не получалось. Интерфейс Blender отличался от интерфейса любой другой программы, с которыми я работал раньше. Я решил повторить попытку и после нескольких недель изучения я стал понимать многие вещи и они стали мне казаться более осмысленными. Вот, что Вы увидите запустив Blender:

Вы смотрите на сцену, состоящую из куба, лампы и камеры (вид сверху). Куб - стандартный меш-объект, созданный в этой сцене, для того, что бы сделав тестовый Рендер можно было увидеть на получившейся картинке объект, а не пустое изображение. Лампа создана, чтобы осветить сцену. И наконец Камера нужна для того, что бы можно было отобразить сцену. Старые версии Blender могут запускаться с различными сценами по-умолчанию (плоскость вместо куба и лампы), но идея остается та же самая. Трехмерный курсор находящийся в середине куба используется, для того чтобы определять место, куда будут добавляться другие объекты. Вы можете перемещать 3D курсор кликая левой клавишей мышки по окну.

В отличее от привычного "выпадающего меню", как в других 3D программах, Blender имеет окно редактирования, находящееся в нижней части экрана. Кликая по кнопкам этого меню - вы попадаете в определенные вкладки. Вы можете изменять тип Окна Редактирования, но пока давайте оставим его таким, какое оно есть.

Blender работает со слоями, так же как другие 3D программы, вы можете перемещать объекты на разные слои, и показывать их, когда это необходимо. Это очень хорошая возможность, потому что при работе с большой сценой - Вы можете включать и выключать слои, с различными объектами. Это будет влиять на скорость отображения сцены и облегчит Вам работу.

Для того, что бы переместить объект на другой слой, Выберите этот объект кликнув по нему Правой Клавишей Мышки (ПКМ) и нажмите кнопку "M", для перемещения объекта. Попробуйте переместить куб на другой слой этим способом. Если вы переместите куб на неактивный слой - он исчезнет из видимости. Для того, что бы сделать слой видимым - просто кликните по нему. А для того, что бы сделать несколько слоев видимыми - удерживая Shift кликайте по иконкам этих слоев.

Совет
Для того что бы выбрать несколько объектов в Blender, удерживайте Shift и правой клавишей мышки кликайте по объектам.


Типы Окон

Blender имеет различные типы окон, и каждое окно может принять любой тип. Например, ваш экран имеет 3 окна, верхнее окно - Панель Инструментов, среднее - 3D Окно и нижнее - Окно Кнопок. Вы можете изменить тип каждого из этих трех окон. Доступные типы окон изображены на рисунке:

Самые интересные для нас типы окон, на данный момент:

- File/Image Browsers (Броузер Файлов/Картинок) - Появляется автоматически при сохранении файла или картинки;

- Buttons Window (Окно Кнопок) - Различные Опции и Настройки Объекта;

- User Preferences (Пользовательские Настройки) - Меню и опции;

- Video Sequence Editor (Редактор Видео Последовательности) - Объединение клипов и эффектов;

- UV/Image Editor (Редактор Изображений/UV) - Для разработки текстур, в частности для игр;

- Action Editor (Редактор Действий) - Для Анимации;

- Ipo Curve Editor (Редактор Ipo Кривых) - Так же используется для анимации;

- 3D View (3D Просмотр) - Для просмотра и работы с моделями;

Окно Пользовательских Настроек

Если Вы установите ваш курсор на линию отделяющую 3D Окно от Окна Пользовательских настроек (вверху), нажмете Левую Кнопку Мышки (ЛКМ) и будете тянуть эту линию вниз - то вы сможете увидеть множество настроек и опций в верхней части экрана:

Интересующие нас, на данном этапе настройки:

• View and Controls (Просмотр и Контролирование) - Здесь вы можете настроить подсказки (появляющиеся, когда вы наводите мышкой на какую-нибуть кнопку) и мышку.

• Edit Methods (Способы Редактирования) - Здесь вы можете настроить количество шагов для опции "Отменить Команду".

• Language and Fonts (Язык и Шрифты) - Настройки языка интерфейса, размер и стиль шрифта.

• System and OpenGL (Система и OpenGL) - Изменнение некоторых настроек системы

• File Paths (Пути к Файлам) - "Обьясняет" Блендеру пути по которым он сможет найти различные файлы

Если вы хотите сохранить эти настройки - нажмите "Ctrl U" и подтвердите появившейся запрос о сохранении настроек по умолчанию. Вы так же можете сохранить настройки через меню File >> Save Default Settings. Будьте осторожны сохраняя настройки по умолчанию - ВСЕ ОБЪЕКТЫ находящиеся в 3D окне(а так же их положение) будут сохранены по умолчанию. Это значит, что при запуске Blender эти объекты будут отображаться в тех же позициях как и при сохранении настроек.


Открытие, Сохранение и Прикрепление Файлов

В Blender так же как в других 3D программах есть функции Открытия и Сохранения файла, однако с некоторыми исключениями. Другие программы используют команды "import" и "insert" для того, что бы открыть или добавить сцену. В Блендере есть подобные функции - "Open" и "Append". Если вы хотите добавить в свою сцену объекты (лампы, камеры, материалы и т.д.) из другого файла Blender (.blend) - Вам нужно использовать команду "Append". Если вы хотите использовать в Блендере сцены, созданные в других программах - Вы можете использовать команду "Open".

Blender поддерживает типы файлов VRML (.wrl) и .DXF. Это прекрасно, потому что большинство 3D программ использует эти типы файлов, в качестве экспорта работы. Blender замечательно работает с экспортированными файлами из других программ. Практически никогда не бывает проблем с экспортированными моделями.

Команда Сохранения

Когда вы впервые начинаете работать с Blender, кажется почти невозможным понять, как сохранить свою работу. Файл интерфейса практически аналогичен старому MS-DOS. Кроме того, каждый раз, когда вы сохраняете работу в существующий файл, происходит резервное копирование этого файла, резервная копия сохраняется с новым расширением (.blend1). Вот что вы увидите, когда нажмете команду Сохранить "Ctrl S":

Команда Прикрепить

Когда Вам нужно вставить в вашу сцену какой-либо объект из другого файла Blender(.blend) - Вам необходимо воспользоваться функцией "Append", которую можно найти в выпадающем меню "File". После этого вам необходимо указать Блендеру, где ваш .blend файл находится(указать путь к файлу). Вы можете вставить в свою сцену такие объекты как: камеры, лампы, меш-объекты, прочие объекты, а так же материалы и текстуры и т.д. Чаще всего используется поле Object (см. рисунок). Для добавления в сцену объектов, материалов, текстур и анимации. Правой Клавишей Мышки (ПКМ) кликните по любому объекту в поле Object для того, чтобы его выбрать(или отменить выбор). Нажатие кнопки "A" выделит все объекты. После того, как вы выверите объект нажмите на кнопку "Load Library" в правом верхнем углу экрана.


Упаковка Данных

Если Вы планируете открывать свой файл .blend на других компьютерах, вы должны использовать функцию "Pack Data" (Упаковка Данных), которая находится в меню "File".

Текстуры и аудио не сохраняются автоматически в файле .blend, что бы сохранить размер файла небольшим. Каждый раз, когда Вы открываете Ваш файл, он ищет текстуры и звуки по определенным ссылкам, и помещает их в вашу модель. Если он не сможет найти по известным ему путям картинки текстур или аудио - у вашей сцене эти элементы будут отсутствовать. При "Упаковки Данных" файлы текстур и аудио будут включены в файл .blend. Теперь вы можете открыть без потерь свой файл на любом компьютере, однако размер файла увеличится. Если Вы упакуете данные, в верхней части экрана появится изображение коробки - это знак того, что данные успешно упакованы. Вы так же можете выполнить операцию обратную упаковке - "Распаковка", для того что бы сделать файл прежнего размера. Для этого в меню "File" выберите "Unpack Data".


Импорт Объектов

Одной из сильных сторон Блендера является способность программы работать с типами файлов, созданными в других 3D программах. Самые популярные описаны ниже:

Файлы VRML (.wrl) Множество программ имееют возможность экспортировать в файлы VRML. Хороший пример - SolidWorks. Эти файлы импортируются в Блендер без проблем, в большинстве случаев.

Файлы .DXF Этот очень популярный формат использует для экспорта такие программы как AutoCAD и SoftPlan. Опять же, Блендер работает с этим форматом безупречно.

Что бы сохранить файл в одном из этих форматов, в другой программе, вы долины найти в ней опцию "export " (экспорт) или "Save as" (Сохранить как), в зависимости от программы, которую вы используете. Прочитайте справочное руководство этой программы.

Чтобы импортировать VRML или файл DXF в сцену Блендера, Вы должны воспользоваться функцией "Open" в меню "File". Программа знает, что вы пытаетесь открыть нечто иное, чем .blend файл, и вставит его содержимое в текущую сцену. Теперь вам нужно найти объект(ы), который Вы только что добавили. В зависимости от того, каким образом этот объект был разработан, его, возможно необходимо будет повернуть или или изменить объекту размер.

С каждой новой версией Blender, список форматов импорта/экспорта увеличивается. Это делает Blender более совместимым с другими разнообразными 3D программами моделирования и анимации. Вы должны уметь находить формат файла в списке, с которым будет работать Blender.


Глава 2: Работа с Окнами Видов

Создаем Окно Видов (или дополнительные окна)

В большинстве случаев, для работы вам необходимо более одного 3D окна, что бы вы могли правильно расположить объект в трех пространствах. Большинство программ рендеринга и анимации, позволяют работать с разными направлениями просмотра. Blender так же поддерживает эту функцию. Как вы знаете, при запуске Blender отображает 3 окна: "Окно Пользовательских Настроек", "3D Окно" и "Окно Кнопок". Вы можете изменить размер каждого из этих окон, просто потяните Левой клавишей мышки за линию отделяющую окна. Как вы можете заметить, указатель мышки при наведении на эту линию изменился, он стал похож на две стрелочки, указывающие верх и вниз. Если вы хотите разделить окно на две части - наведите указатель на эту линию и кликните Правой клавишей мышки, в появившемся меню выберите "Split Area".

С помощью появившейся линии вы можете определить положение и размер нового окна. Объединить окна можно почти тем же самым способом (в меню вместо "Split Area" нужно выбрать "Join Areas"). Вы можете разделять окно сколько угодно раз. Я обычно работаю с двумя 3D окнами как на примере слева. В левом окне я настраиваю рабочие режимы просмотра (вид сверху, спереди и с боку), а правом окне у меня вид из камеры или Редактор анимации (немного позже я расскажу об этом).

Окно можно разделить так же и по вертикали. Некоторые 3D программы традиционно имеют 4 Окна Видов (вид сверху, спереди, справа, в перспективе или вид из камеры).


Изменение Оконного Типа

Теперь, когда Вы добавили несколько Окон Видов, вспомните, что типы окон можно менять. Когда вы станете более знакомы с Blender, вам будут необходимы такие типы Окон как "Редактор Ipo" и "Редактор Действий".

Опции Окна Кнопок

Традиционно Окно Кнопок в блендере расположено внизу экрана, однако это окно можно расположить справа, как в некоторых 3D редакторах. Это было сделано для того, чтобы сделать изучение программы легче для новичков. Что бы расположить Кнопочное меню с правой стороны, для начала вы должны разделить ваше 3D Окно на 2 части, а затем в правом окне изменить его тип.

Смотрится неплохо, но требуются некоторые настройки. Кнопки расположены в окне горизонтально, поэтому большую их часть не видно. Что бы это изменить кликните по этому окну Правой клавишей мышки и в появившемся меню выберите вертикальное расположение кнопок - "Vertical".

Для изменения размера кнопок в окне вы можете использовать "+" или "-" на Нумпаде. Нажмите среднюю клавишу мышки (без прокрутки) для перемещения кнопок в окне. Я все же предпочитаю пользоваться кнопками редактирования внизу экрана, но это еще одна возможность.


Передвижение по 3D пространству

В 3D программе, Вы должны думать не только о том как расположить объект в 2 пространствах (высота и ширина), вы должны просчитать так же глубину объекта (3 измерение). Прежде, чем Вы сможете работать в трехмерном пространстве, Вы должны получить некоторые навыки в 2-D рисовании и верстке. Навигация в 3D окне осуществляется мышкой и Клавиатурным Нумпадом. Существует 3 стандартных вида отрисовки - вид сверху, вид спереди и вид справа. Эти виды можно вызвать с помощью кнопок Нумпада - 7 (вид сверху), 1 (спереди), 3 (справа). Поместите Ваш курсор в 3D окно и попробуйте нажать на клавишу какого-нибуть вида на Нумпаде. Нажав 0 (ноль) - Вы попадете в "вид из камеры" (вы теперь видите то, что видет камера).

Камера представлена 3 прямоугольниками. Внешняя сплошная линия - предназначена для того, что бы кликнув по ней, вы могли выбрать камеру. Следующий пунктирный прямоугольник - это лимит видимости камеры. А внутренний пунктирный прямоугольник - помогает вам отцентрировать положение объектов в камере.

Кнопка "5" на вашем Нумпаде - переключение между ортографическим и перспективным режимом просмотра. Клавиши Нумпада со стрелками (это кнопки 2, 4, 6, 8) позволяют вам вращать вид отрисовки в 3D пространстве. Кнопки "+" и "-" позволяют увеличить или уменьшить масштаб отображения. Кнопка "." (точка) позволяет вам сосредоточить центр вашего вида на выбранном объекте.

Мышка так же выполняет много функций. Левой Клавишей Мышки, можно перемещать 3D курсор, растягивать окна и выделять объекты. Новые объекты будут добавляться в то место, где расположен 3D курсор. Позже мы рассмотрим возможности, которыми обладает 3D курсор. Правая клавиша используется для выбора объектов или вершин (в Режиме Редактирования). Средняя Кнопка Мышки служит двум целям. Прокрутка колесика, увеличивает или уменьшает масштаб отображения (как клавиши Нумпада "+" и "-"). Нажав на Среднюю клавишу - вы сможете вращать вид отображения. Так же Удерживание Средней Клавиши Мышки в сочетании с Shift - позволит вам двигать вид отображения.

Совет
Перед тем как перейти к следующим урокам, потренируйтесь пользоваться этими опциями. Без этих знаний - Вам будет тяжело освоить дальнейший учебный материал.

Теперь, когда Вы знаете как изменять вид просмотра и как передвигаться по 3D пространству, мы можем перейти к созданию объектов в Blender!

Типичные Виды Отображения и их Кнопки

Это некоторые виды отображения, использующиеся в 3D моделировании и кнопки на Нумпаде, которые вызывают эти Виды отображения. Что бы эти кнопки работали - необходимо включить Нумпад (нажатием кнопки Num Lock). Используйте эти примеры для работы с Видами отображения (вид сверху, спереди, сбоку) в ортографическом режиме.


Практическое Занятие

Направления Просмотра

Чтобы получить немного опыта в использовании этих команд, настройте экран с четырьмя видами отображения: видом сверху, спереди, сбоку и с видом из камеры или перспективным отображением, как показано ниже:

Ответьте на следующие Вопросы:

- Как передвинуть вид отображения?
- Как увеличить масштаб отображения (zoom)?
- Как изменить Тип Окна?
- Как сосредоточить центр вашего вида на выбранном объекте?
- Как переключаться между видами (вид сверху, спереди, из камеры, свободное вращение)?


Глава 3: Создание и Редактирование Объектов

Работа с основными Меш-объектами(mesh)

Теперь, когда мы хорошо знаем как передвигаться в 3D пространстве Blender, давайте перейдем к основам конструирования и формирования объектов. В это главе мы будем говорить о создании основных форм и использования модификаторов, для их формирования. Существует много различных типов объектов для моделирования в Blender. В этой части книги мы будем обсуждать Меш-объекты.

Создайте новую сцену в Blender и сохраните файл в своей директории. Назовите файл sculpture.blend. В операционной системе Windows XP для того, что бы это сделать нужно:

1. Зайти в Меню File и выбрать в нем Save.
2. Выбрать диск C: (читайте об том как сохранять файлы в главе 9).
3. Нажать на "Documents and Settings", найти свою папку.
4. Далее перейдите в директорию, куда вы хотите сохранить файл.
5. Введите имя для файла sculpture.blend и нажмите [Enter], затем подтвердите запрос о сохранении.

Совет
Blender не сохраняет ваш файл при выходе из программы. Не забывайте сохранять свои файлы!

Размещение Объектов в 3D Окне

3D курсор (красно-белый круг) используется для размещения новых объектов. Используйте Левую кнопку мыши, чтобы переместить курсор в трехмерном пространстве, когда вы найдете хорошую позицию курсора, нажмите [Space] для вызова основного меню. В этом меню выберите "ADD", затем "Mesh" и затем "UV Sphere".

Вы должны ответить на вопрос в появившемся меню: Какое Количество Сегментов и Количество Окружностей вы хотите использовать. Вы можете изменять данные в этом меню с помощью мышки, нажимая на стрелочки или удерживая Shift кликнуть по числовому полю. После этого Вы сможете ввести желаемое число. Вы можете оставить значение по умолчанию - 32.

После этого Ваша сфера должна появиться в 3D окне.

Когда вы добавляете объект в Blender, он находится по-умолчанию в Режиме Редактирования. В Blender'е есть два основных режима - Режим Редактирования и Объектный Режим. Режим Редактирования предназначен для изменения формы объекта, путем выделения вершин на объекте. Объектный Режим влияет на объект в целом. Клавиша Tab переключает Вас между этими двумя режимами.

После добавления объекта в вашу сцену, нажмите кнопку Tab, чтобы выйти из Режима Редактирования. В противном случае следующий добавленный объект, который вы создадите будет присоединен к этому меш-объекту!

Есть еще один способ переключения между режимами Редактирования и Объектным, без использования кнопки Tab - использовать меню в нижней части 3D окна. Обратите внимание, что в этом меню есть несколько режимов, отличных от Редактирования и Объектного . Некоторые из них будут пояснены в следующих главах.

Типы Форм Меш-Объектов

Простейший двухмерный меш-объект, очень подходит для моделирования оснований(пола). Его можно подразделить и используя "Режим пропорционального Редактирования" сделать хорошую холмистую поверхность.

Основной 3D меш-объект. Хорошо подходит для конструирования прямоугольных моделей.

Не отображается как 3D объект, но ее можно вытягивать (экструдировать) и формировать.

Сфера сгенерированная из окружностей и сегментов, она похожа на глобус, состоящий из параллелей и меридиан.

Сфера сгенерированная треугольниками.

Похож на канистру, закрытую с обоих сторон.

Очень похожа на цилиндр, с той разницей, что оба ее основания открыты.

Основная закрытая коническая форма.

Может использоваться и экструдироваться как плоскость.

Забавный меш-объект, который я решил включить в этот список.

Совет
Помните, что всякий раз добавляя объект, он появляется в Режиме Редактирования. Каждый следующий добавленный объект в этом режиме - объединится с уже существующим объектом. После того как Вы создали объект - Не забудьте выйти из Режима Редактирования с помощью кнопки [Tab]. Так же не забудьте, что новые объекты появляются там, где расположен 3D курсор.


Использование Главных Модификаторов для Манипуляции Меш-Объектами

Прежде чем мы начнем изменять формы меш-объектов, мы должны должны хорошо изучить создание, перемещение, вращение и масштабирование основных меш-объектов. Три основных модификации, используемые в Blender (в Объектном Режиме) являются:

кнопка "G" - перемещение объекта
кнопка "S" - изменение размера объекта
кнопка "R" - вращение объекта

Если Вы хотите использовать в вышеперечисленных модификациях точные числа, например повернуть объект по оси Х на 90 градусов или применить точный размер - Вы должны использовать "Цифровое Окно", которое вызывается кнопкой "N".

Совет
Если Вы хотите переместить объект, по определенной оси (X, Y, Z), введите команду движения "G" и нажмите на среднюю клавишу мышки. Это ограничит перемещение объекта по определенной оси.

Использование Виджетов Трансформации

Относительно новая возможность программы - меню виджетов трансформации. Вместо использования команд R, S и G, вы можете активизировать функцию виджета и просто указать ось(кликнуть по изображению оси правой клавиши мышки), которую Вы хотите использовать. Вы так же можете использовать при движении режимы виджетов Global (обычные, X, Y, Z плоскости), Local (X, Y, Z плоскости относительно объекта).


Практическое Занятие

Создание Объектов

Создайте скульптуру, используя как минимум один из каждых типов меш-объектов, находящихся в в меню ADD>>Mesh (не используйте окружность и решетку). Незабывайте выходить из Режима редактирования, перед каждым созданием нового объекта (кнопка Tab). Используйте меш-объект "Плоскость" для создания пола. Разделите свое 3D окно на две части, что бы Вы могли в одном окне использовать рабочие Виды, а во втором - вид из камеры. Поэкспериментируйте с размером и вращением новых объектов. Новые команды:

Размер (кнопка "S")- для изменения размера/масштаба объекта.

Вращение (кнопка "R")- для вращения объекта.

Движение (кнопка "G")- для изменения положения объекта.

Затемнение (кнопка "Z")- используется для переключения режимов каркасного и затемненного отображения объекта.

Не забывайте использовать клавиши видов 1, 3, 7, 0 на вашем Нумпаде. Кроме того поиграйте с расположение камеры для того что бы получить хороший вид!

** Вам не обязательно делать обезьянку - это всего лишь пример использования меш-объектов! **


Режим Редактирования - Редактирование Вершин Меш-Объекта

После того как вы создали меш-объект, Вы можете зайти с ним в Режим Редактирования (кнопка Tab) и изменить его форму. В режиме редактирования, вы можете работать с индивидуальными вершинами меш-объекта (секциями меш-объекта), для создания нужной формы. Вы знаете, что когда Вы находитесь в Режиме редактирования, вы видите розовые или желтые точки выбранного объекта. Розовыми точками обозначаются невыбранные вершины, а желтыми точками выбранные вершины.

Совет
Команда отменить в Режиме Редактирования: Если вы неправильно скопировали или перемести вершины - нажмите кнопку "U" - это вернет Вас на на один шаг назад.

Выделение Вершин:

Находясь в Режиме Редактирования, Вы можете выбрать каждую вершину индивидуально, для этого кликните по вершине Правой клавишей Мышки. Для выбора нескольких вершин, удерживайте клавишу Shift и кликайте по вершинам правой клавишей. Чтобы выделить вершины прямоугольником - нажмите кнопку "B" и выделяйте вершины появившемся боксом. Повторное нажатие кнопки "B" вызовет инструмент выбора окружностью, вы можете регулировать радиус этой окружности с помощью кнопок "+ или "-" на вашем Нумпаде. Прокрутка колеса мышки работает так же как кнопки "+" и "-". Нажатие "Esc", если вы решили закончить работу с этим инструментом выделения. Для того, чтобы выбрать все вершины (или снять выбор в имеющихся вершин) - нажмите кнопку "A"(для выбора всех вершин) и повторно "A" (для снятия выбора с вершин).

Опции Выделения:

Blender имеет дополнительные инструменты, использующиеся при выделении вершин. Вы можете найти эти инструменты в нижней части 3D окна, находясь в Режиме редактирования.

Основные Модификаторы:

После того как вы выделили некоторые вершины, Вы можете использовать основные модификаторы, о которых мы говорили в прошлой главе ("G"- перемещение, "S"- масштабирование, "R"- вращение).

Создание Дополнительных Вершин:

Иногда Вам необходимо добавить дополнительные вершины, во всем меш-объекте или в его конкретной части, для того что бы более детализировать Ваш меш-объект. Чтобы это сделать, надо сначала выбрать все вершины, которые вы хотите подразделить, а затем найдите и нажать кнопку в верхней части Окна Кнопок.(иконка этой кнопки похожа на плоскость в Режиме Редактирования):

Теперь найдите в одной из панелей кнопку Subdivide, нажмите эту кнопку несколько раз, до получения желаемого результата.

Специальное Меню:

В Режиме Редактирования нажмите кнопку "W", эта команда вызовет дополнительное меню, содержащщее опции редактирования. Более подробней об этих опциях Вы сможете узнать немного позже.

Центральные Точки:

Каждый объект, который Вы создаете в Blender имеет маленькую точку в области объекта (по-умолчанию эта точка находится в центре объекта). Эта точка является центром объекта или точкой вращения. Новички в Blender часто непонимают - почему их объекты вращаются, масштабируются не так как должны? Это происходит потому, что при перемещении всего объекта в "Режиме Редактирования" центральная точка отается неподвижной, поэтому центр объекта смещается. Если вы хотите переместить весь меш-объект, сначала выйдите из Режима Редактирования (Tab). Теперь когда вы будете передвигать объект с помощью "G", центральная точка будет двигаться вместе с ним.

Если вам когда-нибуть понадобиться переместить центр объекта, поместите 3D курсор в то место, где вы хотите сделать новый центр, затем найдите кнопку "Center Cursor" в Окне Кнопок. Эта кнопка, а так же еще две находящиеся рядом, изменяют положение центра объекта. Нажав на кнопку "Centre", вершины и грани поверхности объекта переместяться в область нового центра. Если вы активизируете кнопку "Centre New", Програма вычислит математический центр объекта и расположит вершины и грани вокруг этого центра.

Режимы Затемнения

Обычно по-умолчанию, режим просмотра настроен отображать объекты твердыми (затемнеными). Во многих случаях вам придется работать с объектами в Каркасном режиме отображения. Эти режимы влияют на то каким объект будет отображаться. Режимы Затемнения очень влияют на выделение вершин в Режиме Редактирования. В Режиме Твердого Отображения выделются только видимые вершины. А в режиме Каркасного Отображения вы можете выделить все вершины (даже предпологаемые).

Переключение между Режимами Каркасного и Твердого Отображения, осуществляется с помощью клавиши "Z" или выбором нужного режима в панеле инструментов (см. рисунок).

Как Вы заметили в меню иструментов находятся еще некоторые Режимы затемнения. Поэкспериментируйте с этими режимами.

Опции Сглаживания "Set Smooth" и "Set Solid", а так же "Auto Smooth".

Как вы можете видеть, в Режиме Твердого отображения округлые меш-объекты не отображаются гладкими. В кнопках Редактирования вы можете увидеть две кнопки с надписями "Set Smooth" и "Set Solid".

Этими двумя кнопками управляется гладкость или рельефность объекта, которая будет отображаться в Режиме просмотра, а так же будет учитана при рендере изображения. Имеются, так же варианты сглаживания, но об этом немного позже. Опция автоматического сглаживания "Auto Smooth" используется для сглаживания граней объекта на определенное количество ступеней.

Для того, что бы воспользоваться автоматическим сглаживанием, войдите в режим Редактирования (кнопка Tab), выберите все вершины (или часть вершин, которые вы хотите сгладить) и нажмите кнопку "Auto Smooth". Выйдите из режима Редактирования и нажмите кнопку "Set Smooth". Отрегулируйте, если необходимо значение для сглаживания.

Вытягивание (Экструдирование) формы объекта

Вы можете вытягивать(экструдировать) вершины меш-объекта, нажав кнопку "E" и выбрав в появившемся меню тип экструдирования, будут созданы копии этих вершин, которые вы можете переместить в любом направлении с помощью "G", изменить масштаб с "S", а так же вращать эти вершины с "R". В Blender есть несколько типов экструдирования. Попробуйте поэксперементировать с каждым из этих типов. Обычно, принято использовать тип экструдирования "Region".

Если Вы выбирете этот тип, вершины будут экструдированы строго по определенной оси. Для того, что бы свободно передвигать вершины нажмите на Среднюю Клавишу Мышки (без прокрутки). Ниже приведен пример куба, вершины которого были несколько раз экструдированы в правую сторону с использованием вращения.

Экструдирование - отличная команда для создания длинных туннелей. Она так же хороша, в том случае, если вы не хотите подразделять объект, для того что бы добавить новые детали.


Режим Пропорционального Редактирования Вершин

Режим Пропорционального Редактирования используется для создания новых форм объекта при редактировании вершин. Для вызова Режима Пропорционального Редактирования, в Режиме Редактирования нажмите кнопку "O", или нажмите на маленькую кнопку с кружком, находящуюся в панели инструментов (см. рисунок).

Примечание : Вы можете пользоваться этим инструментов только в Режиме Редактирования.

Режим Пропорционального Редактирования имеет несколько опций редактирования вершин. Мы в основном будем использовать опции "Sharp Fallof" или "Smooth Fallof", но вы можете поэксперементировать с любой из этих опций.

Воздействие Пропорционального Редактирования можно контролировать кнопками "+" и "-" на Вашем Нумпаде или с помощью скрола мышки.

Создание Простого Холмистого пейзажа

Вы можете использовать Пропорциональное Редактирование вершин, чтобы сделать простой холмистый пейзаж. Первое, что нужно сделать - это добавить плоскость из вида сверху (клавиша 7). Находясь в Режиме редактирования, убедитесь в том, что все вершины выбраны (они желтого цвета). Используйте "A", что бы выделить все вершины. Нажмите кнопку "W" для вызова специального меню, в этом меню выберите "Subdivide"(Подразделение). Повторите эту процедуру несколько раз. Теперь выберите одну любую вершину, где-нибуть в области центра.

Теперь перейдите к виду спереди (клавиша 1) и нажмите кнопку "O" для того, что бы войти в Режим Пропорционального Редактирования Вершин. Выберите опцию "Sharp Fallof" или "Smooth Fallof", в зависимости от желаемого эффекта. Двигайте вершину , используя "G". Используйте кнопки нумпада "+" и "-" (или скрол мышки) для того, что бы настроить диаметр воздействия. Экспериментируйте с этими значениями, для получения выпуклой формы. В финале вашей работы сгладьте объект.

Выйдите из режима редактирования (кнопка Tab) и не снимая выделения с плоскости, перейдите к кнопкам редактирования и нажмите на кнопку "Set Smooth". Эта опция должна сгладить объект. В самом конце нажмите кнопку "Z" для того что бы увидеть объект заполненным.


Практическое Занятие

Базовое Редактирование

Откройте ваш файл sculpture.blend, созданный на прошлом практическом занятии. И измените его объекты, используя те методы редактирования, которые Вы узнали в этой главе. Используя Инструменты Пропорционального Редактирования измените плоскость (пол). Используйте экструдирование для добавления новых деталей или модификации существующих. Используйте такие Модификаторы как: Подразделение ("Subdivide"), перемещайте или масштабируйте вершины в Режиме Редактирования. Для сглаживания используйте функцию "Set Smooth", находящуюся в кнопках редактирования. Так же не забывайте о режимах затемнения "Z".


Объединение / Разделение Меш-Объектов, Булевы Операции

Теперь, когда Вы хорошо освоили Базовое Редактирование, мы можем перейти к новым опциями, таким как:

Объединение Меш-Объектов

Для объединения двух или более меш-объектов в один объект, удерживая кнопку "Shift" выделите эти объекты. Затем нажмите комбинацию клавиш "Ctrl J". Они сохранят любые материалы, которые Вы создали для них, но станут одним объектом.

Разделение Меш-Объектов

Для того, что бы разделить меш-объект, Вы должны в Режиме Редактирования (кнопка Tab) выбрать те вершины, которые вы хотите сделать независимыми. Когда нужные вершины выбраны, нажмите кнопку "P и выберите тип разделения. Новые версии блендер, позволят вам сделать независимой каждую из всех вершин одновременно.

Удаление Вершин

Если вы хотите сделать отверстие в меш-объекте, выберите какую-нибуть вершину и нажмите кнопку "Delete".

Добавление Граней

Иногда, вам необходимо заполнить отверстия в меш-объекте. Для того, что бы это сделать, зайдите в Режим Редактирования этого объекта и выберите 4 вершины, пространство между которыми вы хотите закрыть (Вы можете выбрать группу только из 3 или 4 вершин). Нажмите кнопку "F", не снимая выделения с вершин. Межу вершинами должна сформироваться грань. Вот пример заполнения пространства между двумя кубами. В режиме Редактирования были выделены по две крайние вершины на каждом кубе (удерживайте кнопку Shift, что бы выделить несколько вершин), а затем с помощью кнопки "F" была добавлена грань.

Команды для создания Кромки

В Режиме Редактирования, вы можете добавить объекту кромку (сглаживание углов), для этого с помощью "W" вызовите специальное меню и в нем выберите команду "Bevel". Однако, кромка может не работать в сложных объектах.

Булевы Операции

С помощью Булевых Операций можно добавлять или вырезать части из меш-объектов, используя другие меш-объекты. Это осуществляется путем выбора двух меш-объектов (в Объектном Режиме) и нажатием клавиши "W". Вы увидите в появившемся меню опции булевых операций "Intersection"(пересечение), "Union"(объединение), и "Difference"(разность).

Вы можете также увидеть модификатора опций, которые позволят Вам иметь 2 оригинальных объекта, и изменять их форму, в зависимости от их пересечения. Ниже, Вы можете видеть результаты действия каждого из этих типов:

Совет
После применения опций Булевых Операций, создается новая модифицированная копия базовых меш-объектов. Вы должны удалить или переместить базовые объекты, для того что бы увидеть новые объекты.

Опции Булевых Модификаторов

В новой версии Blender появился новая возможность моделирования - "Панель Булевых Модификаторов". Это еще один способ создания Пересечения, Объединения или Разности меш-объектов. Для добавления модификатора, выберите объект, который Вы хотите модифицировать, затем перейдите к Кнопкам Редактирования, там найдите вкладку "Modifier" и нажмите на кнопку "Add Modifier".

В появившемся списке доступных модификаторов стоит выбрать "Boolean". В панели модификатора, введите имя второго объекта, выберите тип Булевой операции "Difference" и нажмите кнопку "Apply". Меш-объект должен деформироваться.

Для того что бы узнать имя объекта, выделите его - имя должно появиться в нижней левой части 3D окна.
Регистр Имеет Значение !


Практическое Занятие

Булевы Операции

Сделайте простую модель домика как показано в примере, используя методы редактирования которые вы знаете. Сохраните этот файл как house.blend.

Начните с создания куба. Создайте так же несколько кубиков поменьше, поместите их внутрь первого куба. С помощью Булевых операций разницы и пересечения ("Difference" и "Intersect") сделайте отверстия для окон и двери. Создайте крышу, используя куб, немного изменив его форму в Режиме Редактирования. Добавьте плоскость для пола. Не стесняйтесь добавлять свои детали!


Глава 4: Лампы и камеры

Типы Ламп, а так же их Настройки

Создавая сцену в Blender, вы начинаете работу с несколькими основными элементами, которые будут видны в камере, возможно даже с лампами. Запомните, - то что вы видите в камере будет отбраженно в финальном отрендеренном изображении или анимации. Для того, что бы сделать рендер изображения - просто нажмите "F12". В открывшемся окне будет отображена часть сцены, на которой сфокусирована камера. Если изображение черное, значит в вашей сцене не установлено освещение или положение или настройка освещения является не правильным. Для того что бы выйти из окна рендера нажмите кнопку "Esc".

В большинстве случаев, вам понадобится более одной лампы для того чтобы правильно осветить вашу сцену. Большинству сцен, как правило, требуются 3-4 лампы. Онако, слишком много ламп - это тоже не хорошо! Различие типов ламп, которые Вы можете использовать, заключается в следующем :

Lamp - Основная лампа в Blender - излучает одинаковое количество света во все направления.

Area - Новый тип лампы - обеспечивает освещение большой площади (например, классной комнаты).

Spot - Освещение под определенным углом.

Sun - Освещение постоянной интенсивности, вне зависимости от расположения объектов.

Hemi - Широкое освещение, подобное освещению лампы Area.

Традиционно в Blender отбрасывать тень может только лампа Spot, однако с помощью новой опции Raytracing (мы обсудим эту опцию в этой главе, немного позже) каждая лампа сможет отбрасывать тень.

Настройки Лампы:

Что бы создать Лампу, установите 3D курсор в нужную позицию и нажмите Space, в появившемся меню выберите Lamp (Лампу), а затем ее тип. После этого лампа будет добавлена в вашу сцену. Вы можете настроить дополнительные опции для лампы. Не снимая выделения с лампы, кликните по кнопке "Shading" (Затемнение), а затем по кнопке Lamp(Лампа), для того что бы получить доступ к настройкам:

Вот, что Вы увидите:

Совет
Вместо того, чтобы добавлять много ламп, поэкспериментируйте с параметрами Distance (Дистанция) и Energy (Энергия)

Вам доступны так же другие настройки Лампы, но в настоящее время мы рассмотрим только основные.

Настройка Лампы Spot (прожекторная лампа).

Лампа Spot уникальна тем, что с помощью нее вы сможете сделать туманное освещение, вместе с тем лампа спот - это традиционная лампа в Blender, которая отбрасывает тень. С Raytracing (обсуждается немного позже в этой главе) каждый вид ламп может отбросить тень, но использование этой функции приводит к более сложным расчетам рендера, поэтому время на отрисовку изображения потребуется гораздо больше. Если вы просмотрите некоторые профессионально выполненные мультипликации, идущие по телевизору, то увидите, что Raytracing с рефлекторностью не всегда используется - из-за рендерного времени (время, которое необходимо на отрисовку изображения.). Эту функцию используют только при необходимости. Давайте рассмотрим настройки лампы Spot.

Для того, что бы тени, отбрасываемые лампой отображались при рендере (F12), вам необходимо в окошке Кнопок Рендера найти кнопку "Shadows" и нажать на нее. Если кнопка "Ray" активна - отключите ее.

Совет
Если тени не отображаются, попробуйте поэксперементировать с опциями "Clip Sta", "Clip End", а так же со значением опции "Shadow Buffer"

Поэкспериментируйте с различными типами ламп, котрые вы теперь знаете. Различные лампы могут быть использованы для получения различных эффектов освещения. Как упоминалось ранее, старайтесь не добавлять слишком много ламп для вашей сцены. Лучшее всего иметь 3-4 лампы и эксперементировать с их положениями, настройками. Вспомните, она с точки зрения освещения реальной ситуации. Вспомните как в реальном мире происходит освещение.


Опции и Настройки Камеры

По умолчанию, в Вашей сцене уже есть одна камера и этой камеры, как правило, вполне хватает для ваших целей. Однако в Блендере есть возможность добавлять дополнительные камеры. Для того, что бы добавить еще одну камеру, нажмите Space, и добавьте новую камеру тем же способом, который мы использовали для добавления всех остальных объектов ранее. Что бы сделать эту камеру активной, выберите ее и нажмите комбинацию "Ctrl 0". Это сделает дополнительную камеру активной.

Как и все другие объекты в Blender, камеру можно настраивать. С выбранной камерой перейдите к кнопкам редактирования.

Здесь представлены некоторые настройки, которые вы можете изменять:

Lens (Линза) - настройка длины линзы точно так же, как в реальной камере. 35(мм), хорошее, безопасное значение для этой опции.

Start - насколько объект может близко находиться по отношению к камере и быть видимым.

End - насколько объект может далеко находиться по отношению к камере и быть видимым.

SizeM - Значение отображаемого размера камеры.

Orthographic - Используется для отображения реалистичной перспективы из ортографического режима.

Mist - Используется для того что бы показать вам как далеко может видеть камера при использовании Тумана (Об этом в главе 6).

Limits - С помощью линии, показывается диапазон видимости камеры.

Name - Как и для всех объектов, название камеры можно отобразить на экране. Однако имя камеры будет видно только при виде из камеры.

Title Safe - Режим показа внутреннего прямоугольника, предназначенного для от центрирования положения объектов в камере.

Passepartout - Затемнение области экрана вне зоны видимости камеры. Вы можете управлять этим затемнением с помощью находящегося ниже бегунка "Alpha".


Практическое Занятие

Освещение и Камера

Откройте ваш файл sculpture.blend, добавьте освещение и настройте камеру, что бы получился красивый вид для рендера. Создайте 3-4 лампы в вашу сцену и поэксперементируйте с различными типами ламп. Используйте как менее одну лампу Spot и в настройках рендера активизируйте тень. Потренеруйтесь с расположением ламп для хорошего освещения с любой стороны. Для примера вы можете использовать рисунок ниже.


Глава 5: Материалы и Текстуры:

Материалы и Текстуры - с их помощью можно сделать из серой модели - бриллиант. Вы можете добавлять цвет, свечение, делать объекты прозрачными или похожими на траву, камень, ткань, обои и т.д. Мы попробуем побольше узнать об этом в этой главе, так что давайте начнем изучение.

Основные Настройки Материала

Вы сможете добавить текстуру, только после добавления материала объекту. Для добавления материала выберите сначала объект с которым Вы хотите работать. Нажмите кнопку "Shading" и затем кнопку "Material". Теперь нажмите кнопку "Add New".

Вы увидите, что появились дополнительные опции настроек. В вкладка "Material" собраны опции изменения физических свойств отображения объекта. Если Вы хотите сделать ваш объект цветным и не использовать текстуры, вы можете настроить цветовое отображение прямо здесь. На рисунке показаны основные опции редактирования Материала:

Это наиболее используемые настройки панели Материалов. Как вы можете видеть не все настройки описаны здесь, но вы можете самостоятельно эксперементировать с ними, что бы увидеть как они работают. В этой панели находятся так же настройки Raytracing, о котором мы говорили в предыдущей главе. Raytracing позволяет более точно настроить прозрачность и рефлекторность объекта, однако время на рендер изображения так же увеличиться. Даже в профессиональных анимационных роликах Raytracing используется только при необходимости, а не для всей анимации. Вы можете добиться хороших результатов не используя Raytracing, а так же уменьшить рендерное время.

Прозрачность Объекта с Использованием Z-Transparent

Самый простой способ сделать объект прозрачным, а так же иметь при этом быструю скорость рендера - это использовать Опцию Z-Transparent в сочетании с настройкой прозрачности Alpha. Во вкладке Links and Pipeline нажмите на кнопку Z-Transp, затем уменьшите значение Alpha. Нажмите кнопку "F12" для того, что бы отрендерить изображение. Если Вы хотите использовать дополнительные эффекты, такие как искажение (преломление) лучей, то Вам необходимо использовать функцию Ray Transparent. Эффект -преломления выглядит так, как будто Вы смотрите на объект через увеличительное стекло или кристалл. Эта функция будет подробно описана в следующей главе.


Настройки опции материала - Hallo (Ореол)

Объекты использующие тип материала Hallo, при рендере в основном отображают только свои вершины. Эффект Hallo может сделать на каждой вершине объекта светящуюся звездочку. Иногда с помощью этой функции можно добиться интересных эффектов. Например, добавляют плоскость и удаляют все ее вершины кроме одной. Эта одна вершина может стать падающей звездой или эффектом сигнальной ракеты при анимации. Если этот тип материала связать с Системой Частиц - можно получить много интересных эффектов. Если вы нажмете на кнопку "Hallo" в панели материалов, то сможете увидеть следующие опции:

Различные Настройки Hallo:

Размер ореола Hallo также можно анимировать, для получения эффекта сужения и расширения ореола. Об Основах Анимации мы поговорим в следующих главах. На примере показаны некоторые опции Hallo. Halo также используются для управления размером и видом частиц в эффектах дыма и огня. Мы так же обсудим это в следующих главах. Вы можете свободно эксперементировать с остальными опциями Материала типа Hallo.


Практическое занятие

Применение Материалов

Откройте ваш файл sculpture.blend и добавьте материал всем вашим объектам. Добавьте как минимум один прозрачный материал (используйте кнопку ZTransp и для настройки прозрачности Alpha), а так же один материал типа Halo. Вы можете создать для материала Halo новый объект, например плоскость с единственной вершиной (остальные 3 вершины нужно удалить). Попробуйте изменить названия всех созданных Вами материалов, чтобы их было легко использовать для других объектов. В финале нажмите кнопку "F12" для того что бы сделать рендер.


Основные Настройки Текстуры

После того, как Вы создали Материал, Вы наверное хотите придать объекту некоторую текстур ность, то есть, сделать объект похожим например, на камень, ткань или ковер. Нам необходимо добавить Текстуру - кликните по кнопке текстур, находящейся справа от кнопки материалов.

После нажатия на "Add New" вам предоставиться выбор имеющихся в Blender типов текстур. Теперь Вам нужно сделать для себя выбор: использовать стандартные типы текстур Blender или Вашу .Jpeg картинку в качестве текстуры. Blender может использовать в качестве текстуры любую картинку формата JPEG (.jpg), фотографию или сделанную с помощью 2D редактора. Blender даже может использовать видео-ролик в качестве материала для объекта! Это очень хорошая возможность если Вы хотите добавить анимацию внутрь вашей анимации.

Совет
Вы не можете добавить Текстуру без предварительного добавления Материала. Материал и Текстуры работают вместе!

Встроенные в Blender Текстуры:

Допустим, вы хотите использовать одну из встроенных в Blender текстур. Давайте рассмотрим такие типы текстур: Clouds (Облака), Stucci (Штукатурка), Magic (Магия), Marble (Мрамор) и Wood (Дерево).

После небольшой практики Вы сможете добиться интересных эффектов, с помощью этих текстур. Если вы выберите любую из них, то увидите, что справа появилась новая вкладка с настройками. Каждая текстура имеет различные инструменты для работы, но существует некоторое сходство между всеми этими текстурами: Большая часть опций текстур Blender'а - работают с шумом и турбулентностью (хаотичностью образца). Деревянная текстура также имеет некоторые возможности воздействия на образец - эффект зернистости дерева (полосы и кольца). После того, как Вы установите Текстуру, Вам прийдется снова вернуться во вкладку Материалов, для тонкой настройки текстуры вашего Объекта. Текстуру Stucci немного дольше настраивать, мы поговорим о ней позже, в этой главе.

После того как Вы добавите текстуру для вашего объекта, вам необходимо вернуться назад к Кнопкам Материала для корректировки новой текстуры. Для примера, давайте используем текстуру типа Marble (Мрамор). Когда вы вернетесь в панель Материала Вы увидите следующее:

Вау, образец-куб выглядит красиво, но я никогда в жизни не видел серо-розовый мрамор :) Пришло время настроить цвет. Основной цвет Материала вы можете установить с помощью бегунков R, G, B.

Для того, что бы избавиться от розового цвета, вы должны перейти в вкладку "Map To" и затем отрегулировать в ней цвет, с помощью бегунков. Теперь Вам необходимо настроить размер текстуры. Для этого, кликните по вкладке "Map Input"(она находится рядом с "Map To"). В этой вкладке Вы должны найти бегунки настройки Смещения (OfsX, OfsY, и OfsZ) и Размера (sizeX, sizeY, и sizeZ). С помощью бегунков OfsX, OfsY, и OfsZ - вы можете двигать текстуру в различных направлениях, по вашему объекту. Значение для размера Size(X, Y, и Z) по умолчанию равно 1 (100%). С помощью бегунков вы можете увеличивать или уменьшать размер текстуры.

Для того, что бы ввести точное значение для смещения или размера - кликните по бегунку Левой клавишей мышки, удерживая Shift. В Blender'е этот метод работает для всех полей ввода информации. В большинстве случаев вполне достаточно корректировки X и Y ползунки. Нажмите "F12", чтобы увидеть вашу отрендеренную сцену, и если понадобиться, подкорректируйте вашу текстуру. Немного практики и терпения и Вы сможете с легкостью редактировать текстуру.

Текстура Stucci:

Текстура Stucci создает интересный эффект на поверхности вашего объекта. В Кнопках Текстур, выберите этот тип текстуры. Затем вернитесь к кнопкам Материала и кликните по вкладке "Map To". Активизируйте кнопку "Nor" для нормального отображения. Как вы можете видеть под кнопкой "Nor" есть бегунок с таким же названием. С помощью этого бегунка вы можете регулировать количество эффекта. Поиграйте с этой опцией для получения холмистого эффекта. Настраивая эту текстуру как мраморную текстуру, Вы можете добиться мелко-зернистого эффекта.


Использование Jpeg в качестве Текстуры

Встроенные текстуры Blender - хороши, но не идеальны. Иногда Вам необходимо наложить на модель такие текстуры как трава, металл, ткань. Любое изображение, имеющее формат .jpg может использоваться блендером, как текстура. Если вы хотите разместить фотографию вашего лица на объект - это возможно! Видео-клип формата .AVI можно поместить в объект, как материал. Для того, что бы использовать изображение .jpg как текстуру Вам необходимо добавить материал, как и раньше, перейти к Кнопкам Текстур и выбрать тип текстуры "Image". Когда Вы выберите эту текстуры перед Вами откроются ее настройки, примерно такие:

Load Image - нажмите на эту кнопку чтобы загрузить изображение, которое вы хотите использовать в качестве текстуры. Если вы нажмете на эту кнопку удерживая "Ctrl" - вы сможете выбирать изображение в режиме предварительного просмотра.

Rot 90 - поворот загруженного изображения на 90 градусов.

Movie - Загрузка видео-клипов в качестве текстуры.

Anim and Movie - в этой вкладки находятся настройки загруженных видео-клипов.

X repeat, Y repeat - Используйте для дублирования загруженного изображения в текстуре, по оси X или Y.

Теперь удерживая "Ctrl" и кликните по кнопке "Load Image" , Вы можете видеть список изображений в текущей папке. Если Вы при нажатии "Load Image" не будете удерживать "Ctrl" - Вы сможете увидеть список названий картинок, без предварительного просмотра картинок. Укажите путь к файлу вашей картинке. Blender можно настроить так, чтобы он всегда показывал одну и ту же папку, если Вы нажмете на кнопку "Load Image" (Об этом читайте тут).

После того, как Вы загрузили изображение,давайте изменим настройки этой текстуры. Вы можете внести дополнительные поправки изображения, а так же использовать другие типы текстур, для комбинации эффектов.(например, текстуру типа Stucci можно использовать вместе с Вашей текстурой "Image"). Что бы так сделать, кликните по пустому текстурному каналу списке текстур (см.рисунок), затем нажать кнопку "Add New".

Когда Вы закончите с Текстурами, вернитесь к кнопкам Материала, для дополнительной корректировки. Перейдите во вкладку "Map Input" и Вы увидите следующие настройки:

С помощью опций Flat, Cube, Sphere, Tube - вы можете изменять способ наложения текстуры, смотрите примеры:


Карта Смещения

Карта Смещения - это новый эффект Blender начиная с версии 2.32. Карта Смещения используется для деформации меш-объекта, с помощью текстуры. В принципе, можно сделать так, чтобы куб, сфера и др. объекты выглядели помятыми (сморщенными) без перемещения их вершин. Для того, что бы посмотреть как работает Карта Смещения создайте куб или сферу. Если вы решили работать с кубом, зайдите в его Режим Редактирования (Tab) и выберите все вершины, нажмите кнопку "W" для вызова Специального Меню и подразделите его (опция subdivide) несколько раз. Карта Смещения работает с вершинами и, если у Вас будет мало вершин на объекте - Вы не добьетесь желаемого эффекта деформации. Далее, добавьте объекту материал и текстуру. Я использовал встроенную в Blender текстуру типа "Clouds". Так же я вернулся к кнопкам Материала и ввел следующие настройки:

Перейдите во вкладку "Map To" и найдите в ней кнопку "Disp", нажмите эту кнопку, тем самым Вы активизируете Смещение текстуры. Теперь найдите бегунок внизу панели, который называется так же "Disp". С помощью этого бегунка увеличьте значение Смещения и нажмите "F12" для того, что бы сделать рендер. Карта Смещения зависит основном от цветов Текстуры. Этим так же можно управлять.

Теперь Вы можете видеть эффект смещения. Для того, что бы узнать как контролировать смещение текстуры с помощью цвета, давайте создадим в 2d редакторе изображение, используя только белый, черный и серый цвет.

Серый цвет при смещении текстуры - остается нейтральным, белые области будут выдвигаться наружу, а тех местах где есть черный цвет - появляться углубления. Если накладывать такую текстуру на меш-объект с множественными подразделениями (много вершин), Вы можете получить интересную модель.


Практическое Занятие

Применение Текстур

Откройте ваш файл sculpture.blend и добавьте текстуры всем объектам вашей сцены. Используйте как минимум один раз:

1. Не используйте текстуру для одного объекта Вашей сцены.

2. Сделайте для одного объекта прозрачный материал (функция "ZTransparent" и "alpha") с текстурой или без.

3. Добавьте к одному из материалов текстуру типа Stucci.

4. Добавьте к одному из материалов текстуру типа Cloud или Marble.

5. Добавьте к одному из материалов текстуру типа Wood.

6. Сделайте материал использующий картинку .jpg, как текстуру.

Сделайте в финале Рендер "F12".


Глава 6 : Настройки Окружения

Использование Цвета, Звезд и Тумана

Вы сделали очень красивую сцену со скульптурой (sculpture.blend), но ей не хватает красивого заднего фона. В зависимости от версии Blender, которую Вы используете, на вашем отренндеренном изображении будет либо синий, либо черный задний фон. Это связано с тем,что некоторые рание версии Blender при запуске не имеют созданного по-умолчанию окружения, поэтому у них черный фон, в новых же версиях при запуске создается стандартное окружение, поэтому при рендере мы видим синий задний фон.

Blender предоставляет вам несколько основных типов настроек Окружения. Вы можете управлять цветами в верхней и нижней части фона (Зенит и Горизонт), добавлять звезды, туман, облака и конечно же использовать в качестве фона свое изображение формата .jpg. Для создания Окружения перейдите к кнопкам редактирования Окружения:

Если в Вашей сцене нет Окружения добавьте его, нажав на кнопочку со стрелками и выбрав в появившемся списке "Add New".

У вас теперь появилось стандартное Окружение с синим горизонтом и черным зенитом. Отрендерите Вашу сцену, нажав кнопку F12. Вы можете изменить некоторые основные настойки в панели Кнопок Окружения. Смотрите пример настроек:

HoR, HoG, HoB - настройки цвета нижней части фона (горизонта).

ZeR, ZeG, ZeB - настройки цвета верхней части фона (зенита).

Stars - Этой опцией вы можете создавать звезды в вашей сцене. Также вы можете настраивать растояние между звездами и их размер.

Mist - Используется для добавления тумана в сцену.

AmbR, AmbG, AmbB - Настройки окружающего света.

Туман

Для того, что бы добавить туман в Вашу сцену, Вы должны сначала настроить цвет Зенита и Горизонта (бегунки HoR, HoG, HoB - для горизонта и ZeR, ZeG, ZeB - для зенита). Сделайте средний серый цвет реального тумана. Теперь нажмите на кнопку "Mist", а затем отрегулируйте значения Sta (расстояния действия эффекта от камеры) и Di (густота тумана). Вы так же можете настраивать значение High - регулируя высоту тумана.

Совет
Если вы создали туман и на отрендеренном его не видно, значит у Вас настроено слишком большое значение Di.

Звезды

Для того, что бы использовать Звезды в своей сцене, вам необходимо сначала настроить цвет Зенита и Горизонта ближе к черному. Нажмите кнопку Stars, затем отрегулируйте значения StarDist (растояние между звездами) и MinDist (минимальная дистанция действия эффекта относительно камеры). Вы можете так же настраивать Size (размер звезд) и Colnoise (случайного добавления оттенка к звездам).

Совет
Помните, что вы создаете бесконечное звездное 3D пространство и если вы установите слишком маленькое растояние между звездами, это может привести к слишком длительному просчету компьютера огромного количества звезд


Создание 3D Фона Облаков

Чтобы создать сцену с облаками, вначале создайте Окружение, как было описано выше. Установите для каждого R,G,B бегунка Зенита значение 1, а для Горизонта настройте синий цвет. Теперь перейдите к Кнопкам Текстур и создайте текстуру типа "Clouds" (как Вы можете заметить Текстура теперь ссылается на Окружение, а не на Материал какого-нибудь объекта. Если это не так нажмите на кнопку "World"(см. рисунок ниже).

Теперь вернитесь назад к Кнопкам Окружения и зайдите в вкладку "Texture and Input". Измените здесь значения полей SizeX и SizeY, для получения желаемого эффекта. Если Вы планируете перемещать камеру в вашей сцене, вам необходимо активизировать кнопку "Real". Так же убедитесь в том, что кнопка "Blend" активна.


Использование Изображения в качестве Фона

Если Вы планируете использовать изображения формата .Jpg, в качестве фона в Вашей сцене, то я советую Вам использовать большое изображение с хорошим качеством. Изображения с низким разрешением имеют тенденцию оказывать зернистый и нереалистичный эффект. Для использования изображения в качестве фона, создайте Окружение, как описано ранее и перейдите к Кнопкам Текстур. Выберите тип текстуры "Image" и загрузите картинку, нажав на кнопку "Load Image". Вернитесь к настройкам Окружения. В раних версиях Blender (до версии 2.40), предварительный просмотр текстуры окружения будет выглядеть ужасно! Установите всем бегунками R,G,B Зенита значение 1 (белый цвет). После этого текстура должна выглядеть гораздо лучше. Если вы сейчас сделаете рендер изображения (F12), то вы увидете черно-белый фон. Для того, что бы это исправить, зайдите во вкладку "Map To" и нажмите на кнопку "Zen Up". После этого, цвета фонового изображения должны отображаться правильно. В самой последней версии Blender для правильного отображения цветов, возможно вам прийдеться так же нажать на кнопку "Zen Do".

Финальный рендер изображения с картинкой .jpg в качестве фона.


Практическое Занятие

Добавление Окружения

Откройте ваш файл sculpture.blend и добавьте в сцену Окружение. Экспериментируйте с добавлением различных цветов, а так же звезд, тумана и изображения в качестве фона. Нет необходимости использовать все эти эффекты одновременно, просто попрактикуйтесь работать с ними, что бы иметь общее представление о них. Когда вы добьетесь желаемого эффекта Окружения сохраните его в вашем файле.


Глава 7: Настройки Окна Рендера

Основные Опции

Окно Рендера это то место, где вы можете указать программе каким образом отрисовывать Вашу сцену. Что вы хотите получить в итоге: изображение .jpeg или видео-ролик? Какой размер отображения сцены Вы хотите получить? Хотите ли Вы использовать самое высокое качество отображения? Может вы хотите использовать эффекты размывания или трассировки лучей (Raytracing)? И последнее, в каком формате вы хотите сохранить полученное отображение сцены (рендер)? Все это мы сможем настроить в Кнопках Рендера. Естественно, чем выше качество выдаваемого отображения (рендера) и чем больше размер - тем медленнее будет происходить отрисовка(рендер). Мы рассматривали основы анимации и рендеринга на 2 и 3 странице этого мануала. Что ж, давайте начнем изучение опций настройки рендера. Кликните по кнопке "Scene", а затем "Render".

Интерфейс и Настройки Рендера

Вам необходимо изучить эти многочисленные опции, для того что бы уметь сохранять Вашу работу как изображение или видео-ролик. Некоторые из этих функций будут подробно описаны в следующих главах. А сейчас мы просто хотим узнать, как сохранить отрисованную сцену в формате изображения JPEG (.jpg) или видео формате Windows (. avi).

1. Место Сохранения и Название файла - Нажмите на маленькую иконку с изображением папки, что бы указать место сохранения и название для сохраняемого файла. Это очень хорошая идея для сохранения видео формата .Avi.

2. Кнопка Рендер - Вызывает окно, в котором отрисовывается Ваша сцена. Альтернатива горячей клавиши "F12".

3. Движок Рендера - Blender поддерживает использование других движков рендера. "Blender Internal" - встроенный движок рендера в Blender.

4. Дополнительные настройки - Сейчас нас интересует только кнопки "Shadow" (Тень) и "Ray". Активизируйте "Shadow", если Вы освещаете сцену с помощью, лампы Spot. О кнопке Raytracing мы поговорим в следующей главе.

5. Кнопка Анимации - Нажмите на эту кнопку если Вы делаете анимацию или образцы файлов анимации.

6. Размер X и Y - это итоговый размер отображенного изображения или анимации. Здесь вы можете указать размер вручную или выбрать заданный размер.

7. Предопределенные Размеры Отображения - При нажатии одной из этих кнопок, будет установлен определенный размер X и Y. Я обычно выбираю тип "NTSC", который устанавливает размер отображения 720 x 480 пикселей. Этот размер считается стандартным разрешением для DVD в США и Японии.

8. Позиция Окна Рендера - Эти кнопки определяют, где будет отображаться окно рендера, когда вы нажимаете кнопку "F12" или "Render" . Если Вы хотите изменить положение этого окна, сначало закройте его(если оно у вас открыто), а затем с помощью этих кнопок измените положение. Если теперь сделать рендер, окошко отобразиться в новой позиции.

9. OSA (сглаживание, антиалиасинг) - OSA улучшает качество отрендеренного изображения. Обычно используется значение для OSA - "8". Это значение обеспечит хорошее качество, без особых потерь времени на отрисовку.

10. Motion Blur (Размытость движения) - Используйте эту опцию если вы делаете быстро двигающийся объект и хотите подчеркнуть его движение "эффектом смазанности"(blur).

11. Размер окна рендера в процентах - Пока мы не будем изменять эти настройки. Если Вам кажеться, что размер окна рендера меньше, чем он должен быть, проверьте - включен ли у Вас режим 100% размера. Этими кнопками Вы можете легко изменять размер окна рендера в процентном соотношении.

12. Кнопка Play (Проигрывание) - после того, как Вы сделали анимацию в Blender, ее можно просмотреть нажав на эту кнопку.

13. Начальный и Конечный Кадр - Здесь вы можете настроить с какого кадра будет начинаться и каким заканчиваться ваша анимация.

14. Список Допустимых Форматов Файлов - Здесь вы выбираете формат файла, в котром вы хотите сохранить вашу итоговую отрисовку сцены. Выберите JPEG - если вы хотите сохранить отрендеренное изображение, как картинку или же один из .AVI форматов для того, что бы сохранить анимацию.

15. Количество кадров в секунду (FPS) - Очень важно настроить значение FPS перед тем как начать делать анимацию. Нормальное значение количества кадров в секунду от 25 до 30. Новички-аниматоры часто имеют проблемы со скоростью анимации. Движение в анимации происходит или слишком быстро, или же слишком медленно. Правильный расчет скорости анимации приходит с практикой.

Рендер Изображения формата JPEG (.jpg)

Для того чтобы сделать JPEG изображение, настройте необходимые опции описанные выше. Очень важно выбрать в Списке Допустимых Типов Файлов формат JPEG (пункт 14). Вы можете настроить самое высокое качество изображения (OSA), так как при рендере единственного изображения фактор времени на отрисовку не так важен, как при отрисовке множества кадров анимации. Нажмите "F12" или кнопку "Render". Когда рендер изображения закончится, нажмите "F3". После этого должно открыться окно, в нем можно указать путь к директории в которую вы хотите сохранить изображение, а так же имя для файла. Не забудьте указывать формат .jpg после имени файла, что бы изображение сохранилось правильно. Операционная система Windows не будет знать, как обращаться с изображением без расширения .jpg.


Создание AVI Видео Файла

В главе 9 Вы будете делать свою первую компьютерную анимацию. После того, как Вы создадите все объекты, примените к ним материалы и текстуры, а так же сделаете анимационные кадры Вы должны будете сохранить кадры анимации как видео. Пройдите эти семь шагов, что бы знать как сохранять видео в формате .Avi:

Семь простых шагов для создания видео файла AVI:

1. Выберите в Панели Форматов тип "NTSC" (или введите свой размер).

2. Измените тип файла с JPEG на AVI.

3. Активизируйте OSA.

4. В панели вывода кликните по иконке с маленькой папкой и укажите название файла и путь к директории в которую будут помещаться отрендеренные кадры анимации. Не забудьте также указать расширение .avi после имени файла, иначе Blender поставит кучу цифр в конце файлов (отрендеренных кадров).

5. Укажите начальный и конечный кадр анимации с помощью полей "Sta" и "End". Так же настройте желаемое количество кадров в секунду (FPS).

6. Убедитесь в том, что кнопка Shadow включена. Так же если Вы не используете в своей анимации эффекты трассировки лучей, отключите кнопку Ray.

7. Наконец, нажмите кнопку ANIM, что бы начать анимацию вашей сцены.

А теперь можете просто расслабиться и отдохнуть. Выполнение анимации сцены может занять некоторое время (минуты, часы, дни в зависимости от сложности Вашей анимации и от быстродействия компьютера), пока не произойдет отрисовка каждого кадра.


Практическое Занятие

Рендер Изображения

Мы опять будем тренироваться с файлом sculpture.blend. Настройте хороший вид из камеры, для того что бы отрендеренная картинка хорошо смотрелась. Настройте опции рендера следующим образом:

1. Выберите тип формата вывода - JPEG. Установите 100% качество (поле Quality под списком форматов вывода, по умолчанию там установлено значение 90).

2. Убедитесь, что кнопка Shadow - активна. Иначе на изображении не будет теней!

3. Активизируйте кнопку Osa и установите для нее значение 8.

4. Кликните по кнопке PC для того что бы настроить размер изображения 640 x 480 пикселей.

5. После того как закончиться отрисовка картинки, нажмите F3 и сохраните изображение как Image.jpg.

Дополнительное Задание:

Создайте объект в вашей сцене (например плоскость), добавьте ей материал и текстуру. Используйте в качестве текстуры изображение Image.jpg, которое Вы сделали раньше. Сделайте рендер еще раз. У вас получился эффект "Сцены внутри сцены" :)


Глава 8 - Трассировка Лучей (зеркальное отображение, прозрачность, тень)

Raytracing (Трассировка Лучей) - это новинка в Blender'е, которая открывает новые возможности рендера изображений. Raytracing - настолько важная часть Blender'а, что она была помещена в отдельную главу, используется для моделей с зеркальной и отражающей поверхностью. Эта функция также используется для создания эффекта прозрачности и преломления (искажение изображения через прозрачные поверхности - такие как увеличительное стекло или линза). С помощью Raytracing любая лампа сможет отбрасывать тень, так же вы можете делать различные удивительные эффекты - однако время на отрисовку изображения (рендер) увеличиться. Используйте эту функцию только при необходимости.

Освещение и Тени

Если Вы хотите сделать тень с помощью Raytracing, выберите лампу которая будет отбрасывать такую тень(Raytracing работает с любым типом ламп), и перейдите в панель "Shading" (F5), а затем к Кнопкам управления Лампы. Во вкладке "Shadow and Spot" найдите и нажмите на кнопку "Ray Shadow". Вот и все! Сделайте тестовый рендер Вашей сцены. (Примечание переводчика: советую проверить, активна ли кнопка Ray в панели Рендера "F5").


Отражение (зеркальность) и Преломление (прозрачность и искажение)

Для создания зеркальной или отражающей поверхности объекта, выберите этот объект и добавьте ему материал. Добавьте так же текстуру. В Кнопках Материала, найдите вкладку которая называется "Mirror Transp". Все элементы управления Raytracing, находятся в этой вкладке. Нажмите здесь кнопку "Ray Mirror" и поиграйте с количеством отражаемости (бегунок "Ray Mir").

Прозрачность же активируется кнопкой "Ray Transp". Два главных элемента управления прозрачностью:

1. IOR (Индекс Преломления) - используется для того, чтобы создать эффект Линзы и преломление лучей.

2. Fresnel - Регулирует уровень прозрачности.

Здесь так же есть другие дополнительные опции, с которыми Вы можете не стесняясь эксперементировать.

На этом изображении все объекты (включая даже лампу) используют функцию Raytracing. Для пола была установлена зеркальность, а для сферы - прозрачность.


Практическое Занятие

Трассировка Лучей

Откройте свой файл sculpture.blend и настройте хороший вид из камеры. Добавьте следующие виды Raytracing как минимум один раз:

1. Установите для какой-нибуть лампы тень, используя опцию "Ray Shadow".

2. Сделайте, как минимум один объект Вашей сцены прозрачным, с помощью "Ray Transp".

3. Так же сделайте, какой нибуть объект сцены зеркальным, используя "Mirror Transp".

После этого, сделайте рендер изображения и сохраните его как JPEG картинку.


Глава 9: Основы Анимации

Синхронность, Движение, Вращение и Масштабирование

Теперь, когда мы знаем как создавать модели и как их делать текстурированными, мы можем приступить к изучению основ анимации. Другое название анимации - интерполяция (Ipo). Запомните этот термин, поскольку Blender использует название Ipo во многих различных названиях функций, касающихся анимации. Мы будем изучать Ipo в этой главе. Некоторые функции анимации сложны для восприятия, однако со временем вы сможете с легкостью пользоваться ими. В этом учебнике не описаны все возможности этого огромного раздела Blender, мы рассмотрим только самые основные. Для начала прочитайте еще раз раздел Основы Рендеринга и Анимации.

После того, как Вы настроили сцену и количество кадров в секунду (fps), Вы должны решить, что должны делать ваши "актеры" и с какой скоростью. Основная проблема начинающих аниматоров - неправильная скорость движения объектов в анимации. Не забудьте установить fps в соответствии со временем. Например, вы хотите, что бы камера сделала полный круг вокруг вашей сцены за 3 секунды. Значит общее количество кадров анимации, при значении fps 25, должно быть равно 75.

Движение, Вращение и Масштабирование

Это три основных модификации объекта, которые используются в анимации. Когда Вы создаете ключевой кадр, Blender сам определяет все промежуточные кадровые позиции объекта между двумя созданными ключевыми кадрами (тоесть вам не не прийдется создавать движение объекта кадр-за-кадром, просто укажите положение объекта в начальном и конечном кадре - остальные кадры будут просчитаны Blender-ом автоматически). Для того, чтобы добавить ключевой кадр объекту, перейдите к кадру на котором вы хотите установить ключ, двигайте/вращайте/масштабируйте объект, а затем нажмите кнопку "I". Должно появиться меню "Добавления Ключа" (Insert Key).

В этом меню есть три основных опции: Loc (сохраняет позицию объекта), Rot (поворот) и Size (размер), остальные опции меню - комбинации первых трех. Об опции Mesh, мы будем разговаривать в следующей главе. Выберите тип ключа, в зависимости от той модификации, которую Вы применили к объекту. Теперь перейдите к следующему кадру, в который вы хотите сделать ключевым (в 25, если вы хотите, что бы движение произошло за одну секунду). Снова двигайте/вращайте/масштабируйте объект, а затем нажмите "I" и вставьте второй ключ.

Продолжайте создавать ключевые кадры для вашей анимации. Варианты ключей "Loc" и "Size" - в большинстве случаев работают безупречно, однако стоит уделить внимание ключу типа "Rot"(вращение). Если вы между двумя ключевыми кадрами вращаете объект по очень большому диаметру, то при анимации его вращение может выглядеть странно :( Попробуйте сделать это вращение в несколько шагов, изменяя каждый раз угол положения объекта. Есть инструменты, с помощью которых можно упростить процесс вращения, однако о них мы поговорим позже.

Просмотр Вашей Анимации

Это простой способ просмотра анимации без необходимости отрисовки каждого кадра. Установите номер кадра, начиная с которого вы хотите просмотреть свою анимацию. Установите курсор в 3D окно и нажмите комбинацию клавиш "Alt A". Анимация сразу начнет проигрываться в 3D окне. Blender будет пытаться отображать анимацию с правильным значением fps. Но иногда он не способен это сделать из-за сложности сцены или параметров настройки отображения.

Возможно, движение объектов будет не совсем таким, каким Вы его планировали. Это можно будет исправить, но об этом немного позже.


Работа с Окном IPO

Сложно сделать хорошую анимацию без базовых знаний в области IPO. Если у вас окно разделено на 2 части (это описывалось раньше), измените тип одного окна на IPO Curve Editor (Редактор IPO Кривых).

В этом окне Вы увидите свою анимацию, представленную в графическом виде. Положение, Вращение и Размер, обозначены здесь кривыми. Точками обозначены ключевые кадры. С помощью скрола мышки можно увеличивать или уменьшать масштаб этого окна. Нажав кнопку Tab, вы сможете редактировать каждую кривую индивидуально.

Вы сейчас видите IPO кривые объекта, однако в Blender'е можно анимировать множество различных вещей, включая материалы и настройки окружения. Что бы увидеть различные типы IPO кривых, войдите в меню "IPO type"(см. рисунок).

Для того, что бы анимировать материал или окружение, поместите свой курсор в окно Кнопок Материала или Окружения и нажмите кнопку "I", для того что бы вставить ключевой кадр. После этого Вы увидите разнообразные опции, доступные Вам.

Как упоминалось ранее, когда вы создаете анимацию для объекта Blender автоматически пытается заполнить промежутки между ключевыми кадрами. Вы можете самостоятельно управлять промежуточными кадрами с помощью IPO кривых. Один из способов: кликните по кривой анимации в IPO Окне, которую Вы хотите изменить. Нажмите кнопку "T". Вы можете видеть 3 варианта редактирования:

Constant (Константа)- сглаживание промежуточных кадров отсутствует.

Linear (Линейная) - Линейное сглаживание, его хорошо использовать, если вы анимируете объект перемещающийся строго по прямой, из точки А в точку В.

Bezier (Безье) - тип редактирования по умолчанию, делает сглаженные промежуточные кадры.

* Теперь, если вы нажмете Tab, вы сможете редактировать точки кривой

Иногда каждому виду Ipo кривой, требуется свой вариант редактирования. Это может оказаться довольно сложным процессом, пока вы не получите некоторую практику.

Путь, который проходит куб в анимации с 3 ключевыми кадрами, активизирована опция Bezier.

Путь, который проходит куб в анимации с 3 ключевыми кадрами, активизирована опция Linear.

Давайте рассмотрим способ редактирования кривой в режиме Bezier. Он заключается в в индивидуальном редактировании точек кривой. Сначала выберите кривую, которую Вы хотите редактировать(Loc-,Rot-, Scale- X, Y, или Z) и нажмите кнопку Tab, для того чтобы зайти в Режим редактирования кривой. После этого, каждый ключ теперь обозначается как три точки. Вы можете с помощью "G" передвигать и изменять размер этих "рычагов". Эта техника требует некоторого навыка и практики. Ключи можно, так же перемещать в другую позицию (перемещение ключа из одного кадра в другой).

Расширенные Режимы (Extended Modes)

Когда Вам необходимо анимировать что-то постоянно движущееся (вращение колеса, ходьба человека, и т.д.), нет необходимости создавать ключевые кадры вдоль всего пути. Все что вам нужно сделать - это создать один цикл движения. Выберите кривую, которую Вы хотите "зациклить" и в меню Curve найдите "Extended Mode" и выберите необходимый режим повторения. Например, "Extrapolation" , используется для кругового движения, такого как вращение колеса. "Cyclic" - отлично применим, скажем для ходьбы или покачивания.


Автоматическое Закрепление Кадра Объекту(Keyframing):

Это метод позволяет избежать необходимости каждый раз нажимать кнопку "I", когда Вам необходимо ключевой кадр. Опция автоматического добавления ключа объекту должна быть активизирована в Окне Пользовательских настроек, в самом верху экрана(оттяните вниз горизонтальную линию, что бы увидеть это спрятанное окно). Кликните по кнопке "Edit Methods" , а затем в поле "Action and Object". Начните перемещать, вращать или масштабировать объект, находясь в 1 кадре (или в том кадре, где вы хотите начать анимацию). Теперь перейдите в тот кадр, в который вы бы добавить ключ. Снова перемещайте, вращайте или масштабируйте объект. Теперь вернитесь в первый кадр и нажмите "Alt A" - для просмотра анимации. Кнопка "Action and Object" работает одновременно разными типами объектов сцены (добавляет IPO кривые). "Action" работает с арматурой(костями), а "Object" с меш-объектами.

Совет
Не забудьте выключать Авто Keyframing, когда нет необходимости в его использовании. Он может очень запутать вашу анимацию! Кроме того, не забывайте о новой команде глобальной отмены "Alt-U", потому что Blender не будет вам напоминать о сохранении своей работы. Сохраняйте свой файл регулярно!

В этом разделе рассматривались основы анимации. Анимация с деформацией меш-объектов, анимация вдоль пути, создание костной структуры (арматуры), а так же создание связи "Родитель-Потомок" между объектами, будут обсуждены позже. Лучший способ понять менталитет анимации - это задавать вопросы опытным пользователям и еще, конечно длительная практика.


Анимирование Материалов, Ламп и Настроек Окружения

Теперь, когда вы знаете основы анимации меш-объектов, мы можем перейти к изучению способов анимации Материалов, Ламп и Настроек Окружения. Вначале, выберите лампу или объект, который мы хоти анимировать. После этого перейдите к Кнопкам Редактирования, соответственно, Материалов или Лампы. Наводите курсор на Окно Кнопок и нажмите кнопку "I", что бы вставить настройки (лампы, материалов или окружения) в ключевой кадр. Ниже описаны опции добавления ключа, для материалов, ламп и Окружения.

Опции Анимации Материала:

RGB - Вы можете анимировать изменение цвета.

Alpha - Этой опцией регулируется прозрачность анимируемого объекта.

Halo Size - А этой опцией, можно регулировать размер Ореольного свечения материала типа Halo.

Ofs - Если у этого материала есть текстура, то можно анимировать ее смещение по оси n X, Y и\или Z.

Size - Размер X,Y,Z текстуры объекта, которого вы анимируете.

All Mapping - Используйте эту опцию, если вы хотите за один раз вставить в ключевой кадр все изменения материала.

Опции Анимации Лампы:

RGB - Вы можете анимировать изменение цвета Лампы.

Energy - Вы можете анимировать изменение Энергии(интенсивности излучения) Лампы.

Spotsi - Добавляет в ключевой кадр настройки Лампы Spot, такие как: угол наклона и размер луча лампы.

Ofs - Если Вы используете текстуру, для своей лампы (да, такое возможно!), эта опция добавляет в ключевой кадр положение текстуры по X,Y и\или Z оси.

Size - Размер X, Y , Z текстуры Лампы, так же можно анимировать!

Опции Анимации Окружения:

ZenRGB - Цвет зенита(вверху), может быть анимирован. Может пригодиться например, при анимации восхода солнца.

HorRGB - Цвет горизонта(внизу), опять же может быть анимирован.

Mist - Очень интересный эффект анимации: анимирование тумана.

Stars - Для анимации эффекта звезд.

Offset - Если Вы используете текстуру в качестве фона, вы можете добавлять в ключевой кадр ее положение по оси X,Y и\или Z. Можно сделать анимацию красивых, плывущих облаков.

Size - Размер X, Y , Z текстуры Окружения, так же можно анимировать.

Совет
Запомните, добавляя ключ анимации для этих всех объектов, в окне IPO появляются соответствующие кривые, которые вы можете редактировать.


Практическое Занятие

Создание Анимации

Откройте Ваш файл sculpture.blend и анимируйте различные объекты. Ваша анимация должна состоять из 250 кадров при fps, равном 25. Вы также можете анимировать камеру.

Помимо анимации меш-объектов, анимируйте так же следущее:

1. Анимируйте Материал пола (измените размер и/или смещение текстуры).

2. Анимируйте, по крайней мере одну Лампу(изменяйте ее цвет и/или размер луча).

3. Анимируйте эффекты Окружения (звезды, туман или текстуру).

После этого, Вы должны сохранить Вашу анимацию как видео формат .AVI. Установите следующие настройки Окна Рендера:

1. Начальный кадр - 1, последний кадр - 250. Значение количества кадров в секунду(fps) - 25(получится 10-секундная анимация).

2. Тип размера - PC(640x480).

3. Формат Файла: AVI.

4. Включите OSA и установите для нее значение - 8.

5. Не забудьте про кнопку Shadows.

6. Укажите путь к вашей директории и название для файла Animation1.avi.

7. В финале нажмите кнопку ANIM.


Глава 10: Добавление 3D Текста

Мы узнали как создавать различные объекты в Blender'е, но хотелось бы отдельно поговорить о создании 3D Текста, потому что Текст является очень важным объектом Blender'a. Есть 2 способа создать текст для сцен Блендера. Первый из них - использовать встроенные генераторы текста. Другой метод состоит в том, чтобы использовать внешние программы для создания текста, а затем импортировать текст в Blender. Каждый метод имеет свои преимущества и недостатки. Текст созданный в Блендере можно легко изменять, войдя с ним в Режим Редактирования (кнопка TAB). В кнопках редактирования Текста можно легко изменять его 3D характеристики. Текст, созданный во внешней программе, такой как Elefont, можно импортировать в Blender как меш-объект. Этому Тексту можно добавлять различные эффекты, например "эффект Волны" (будет обсуждаться позже), в этом он лучше 3D Текста Блендера.

Настройки 3D Текста в Blender

Для создания трехмерного текста в Blender, установите 3D курсор в нужную позицию добавления и нажмите Space >> Add >> Text.

В 3D окне должно появиться слово "Text". Текст находится в Режиме Редактирования. Теперь с помощью клавиатуры (как в обычном текстовом редакторе) измените текст и выйдите из Режима Редактирования (кнопка TAB).

Перейдите к Кнопкам Редактирования. В этом окне Вы можете видеть различные опции и настройки 3D Текста. Здесь вы можете придать тексту объем(экструдировать Текст), настроить выравнивание и др. Смотрите объяснение опций на рисунке ниже:

Front/Back - Открытие или закрытие передних и задних стенок текста.

Width, Extrude, Bevel Depth, Bev Resol - Опции для настройки трехмерности текста. Используйте опцию Extrude - если вы хотите сделать текст объемным.

Left, Center, Right, Justifi, Flush - Настройки положения текста

Set Smooth - сглаживание текста

Size, Spacing, Shear - стиль, размер текста

Blender будет использовать шрифты, которые есть в вашей операционной системе. Если у Вас установлена на компьютере операционная система Windows, то шрифты будут найдены на диске C:\, в папке Windows. Ваши шрифты находятся в папке, которая называется Fonts. (Примечание переводчика: Скажу как пользователь Linux, по умолчанию Blender не находит шрифты в /usr/X11/lib/fonts ;), настройте путь к шрифтам в Окне пользовательских настроек). При загрузке шрифта (кнопка Load), доступные шрифты будут обозначены маленьким квадратиком. Некоторые из сложных шрифтов, могут исказиться при экструдировании.


Деформация текста с помощью Кривой

В Блендере возможно деформировать текст с помощью кривой Path. Для добавления кривой Path, нажмите Space >> Add >> Curve, затем выберите Path (или другую разновидность кривой).

Кривая должна появиться в вашей сцене в Режиме Редактирования. Кривую можно сделать желаемой формы. Для этого измените ее в режиме редактирования (Tab). После этого добавьте в сцену Текст и перейдите к его Кнопкам Редактирования.

Найдите поле "Text On Curve". Введите в это поле название кривой (оно отображается в левом нижнем углу окна, когда кривая выбрана. Запомните названия чувствительны к регистру.

Текст примет форму кривой. Может потребоваться изменение расстояния между буквами (опция Spacing), что бы текст принял более правильную форму.

Преобразование Текста в Меш-объект

Иногда необходимо преобразовать Текст в меш-объект, для того, что бы иметь возможность добавлять ему различные эффекты (например эффект "Build", о который мы будем изучать в 12 главе). Чтобы преобразовать текст в Меш-объект, выберите текст и нажмите комбинацию "Alt C". После этого текст преобразуется в кривую. При повторном нажатии "Alt C" Текст преобразуется в меш-объект.

Иногда, Вы можете чувствовать некоторые ограничения текста Блендера (хотя с каждой новой версией, в Blender'е улучшаются инструменты редактирования). В этих случаях, Вы можете использовать внешнюю трехмерную программу текста, такую как Elefont. Он может сохранять файлы в стандартном формате DXF, который поддерживается Блендером.


Использование программы Elefont для 3D Текста

Elefont - Это популярная программа, используемая для создания трехмерного текста, свободно распространяемая (freeware), которую можно скачать с сайта www.armanisoft.ch.

Это простая в использовании программа, в которой возможно сохранять файлы формата .DXF. Если помните, Blender отлично работает с форматами файлов .DXF и VRML (.wrl). Именно поэтому давайте рассмотрим эту интересную, бесплатную программу создания 3D текста:

Q - Настройка "качества" кривой (больше или меньше граней). Кликните левой клавишей мышки по этой кнопке и ведите мышкой влево либо вправо.

E - Экструдирование толщины. Кликните левой клавишей мышки по этой кнопке и ведите мышкой влево либо вправо.

e - Вызывает окошко в котором вы можете видеть экструдированный текст.

B - Настройка кромки - эта опция используется если вы хотите сгладить угры вашего текста.

S - Масштабирование кромки (размер кромки). Кликните левой клавишей мышки по этой кнопке и ведите мышкой влево либо вправо.

F - Экспорт (сохранение текста) в файл .DXF формата.

H - Вспомогательная информация.

После того, как вы создадите 3D текст и сохраните его в формате .DXF, запустите Blender и в меню File выберите Open. Это работает как команда импорта для файлов, не Блендеровского формата. Введите путь к вашему файлу и нажмите кнопку "Open". После этого текст созданный в Elefont появиться в вашей сцене. Текст является обычным меш-объектом. Вы можете добавить тексту материал и модифицировать его, если это необходимо. Если вы хотите объединить все буквы текста вместе - выберите их и нажмите комбинацию "Ctrl J". После этого отдельные буквы текста станут отним целым меш-объектом.

Текст, созданный в программе Elefont в Режиме Редактирования.

Текст, созданный в программе Elefont в объектном режиме и активизированной опцией затемнения "Z".


Создание 3D Текста

Создайте новую сцену в Blender. Затем, создайте 3D текст, используя встроенный генератор текста Blender'а, а так же с помощью программы Elefont. Разместите оба текста на плоскости и добавьте Лампу, которая может отбрасывать тень (Spot или используйте для любой лампы опцию Ray). Добавьте материалы и текстуры всем объектам. Для плоскости создайте отражающий материал (используйте опцию Ray Mirror).

Сделайте рендер и сохраните изображение в своей директории.


Глава 11: Основы NURBS и Метa-Поверхностей

Если Вы нажмете на кнопку "Space", а затем выберите "Add", Вы заметите, что в меню есть объекты отличные от меша, камеры и лампы. Давайте рассмотрим объекты Surface(NURBS) и Meta. В этом учебном пособии мы много говорили о моделировании различных поверхностей, однако стоит обратить свое внимание на эти виды объектов, которые помогут Вам создавать такие интересные эффекты как "капли жидкого металла" и еще многое другое.

Использование NURBS для Создания Изогнутых Поверхностей (Форм)

Обратите внимание, что в меню Surface, есть несколько вариаций Nurbs поверхностей, которые вы можете добавить в сцену. Эти поверхности можно преобразовать в меш-объекты и затем работать с их вершинами. Для преобразования Nurbs поверхности в меш-объект, выделите Nurbs и нажмите комбинацию клавиш "Alt C" (в Объектном режиме). В появившемся окошке подтвердите запрос на преобразование. С помощью Nurbs Вы можете создавать разные интересные модели и существует множество on-line уроков которые помогут Вам в этом. Однако в этом учебнике мы будем рассматривать простейшие методы моделирования с использованием Nurbs. Давайте попробуем сделать туннель, используя NURBS Circle.

Создание 3D Туннеля

Мы создадим несколько NURBS Circle, а затем объединим их вместе.

Добавьте NURBS поверхность: Space >> Add >> Surface >> NURBS Circle. Появившаяся в Вашей сцене поверхность находится в Режиме редактирования. Измените немного форму NURBS Circle, просто выделяйте точки на поверхности и передвигайте их.

Перейдите в вид сверху. Дублирует несколько раз кольца NURBS, используя комбинацию "Shift D".

После этого Вы можете изменить форму каждого кольца индивидуально, для этого выделите кольцо и перейдите в его режим редактирования (кнопка Tab). Затем выделите все кольца NURBS, удерживая Shift, кликайте правой клавишей мышки по кольцам.

Теперь объедините кольца в один целый объект- нажмите комбинацию "Ctrl J".

Перейдите в режим редактирования (кнопка Tab) и выберите все точки (кнопка A). Нажмите "F" и между кольцами образуется поверхность.

Вот туннель и готов! Вы можете, конечно преобразовать его в меш-объект, просто выберите его в объектном режиме и нажмите "Alt C".


Эффект Жидкости и капель с использованием Метa-Поверхностей

В ранних версиях Blender была всего одна разновидность Метa-Поверхностей. Однако программисты заинтересовались этим удивительным 3D объектом Blender'a и помогли в разработке разных Мета-форм. Принцип мета поверхности заключается в том, что две Метa-Поверхности могут воздействовать на форму друг друга. Эти объекты можно анимировать и текстурировать, как и все другие объекты Блендера. Особенно эффектно смотрятся Мета-поверхности с прозрачным или отражающим материалом. Мета-Поверхности создаются тем же способом, что и другие объекты Blender'a.

Первая созданная Мета-поверхность будет родительской для все остальных. Когда вы будете ее передвигать, остальные мета-объекты будут поворачиваться за ней.

Совет
Не забывайте выходить из режима редактирования мета-поверхности (Tab), перед созданием нового мета-объекта. Иначе,все мета-объекты будут объединены.


Практическое Занятие

Мета-Поверхности

Создайте новую сцену в Блендере и настройте окно видов на ваш вкус. Создайте меш-плоскость (Plane) и два любых Мета-объекта. Добавьте материал, текстуру для плоскости и для Мета-Поверхностей. Экспериментируйте с настройками прозрачности и/или отражаемости .

В финале сделайте рендер изображения и сохраните его в свой директории. Попробуйте так же сделать анимацию Мета-объектов.


Глава 12: Модификаторы

Начиная с версии Blender 2.40 был полностью изменен интерфейс некоторых основных инструментов Blender. Был сильно изменен интерфейс основных Модификаторов. Для удобства, все они были помещены в панель Modifiers. Для того что бы начать работать с Модификаторами Вам необходимо добавить объект (для которого будет применен модификатор), затем перейти к его Кнопкам Редактирования (F9) и найти вкладку Modifiers. В этой вкладке нажмите на единственную кнопку "Add Modifier".

Модификаторы, которые мы планируем рассмотреть в этой главе:

- Subsurf
- Build
- Mirror
- Wave
- Boolean

Модификатор Subsurf (Сглаживание меш-объектов)

Модификатор Subsurf применяется в том случае, когда одного использования "Set Smooth" или "Auto Smooth" недостаточно для сглаживания меш объекта. Subsurf подразделит грани меша, но при этом не добавит новых вершин. Это значит, что в режиме Редактирования меш-объект останется таким же как до применения этого модификатора. Смотрите пример использования модификатора Subsurf:

Сюзана без активизированного модификатора Subsurf

Subsurf активизирован и уровень подразделения равен 1

Subsurf активизирован и уровень подразделения равен 2

Совет
Не устанавливайте слишком высокий уровень подразделения. Это может негативным образом отразится на скорости работы компьютера.


Эффект Построения(Build)

С помощью Эффекта Построения, можно имитировать линейное исчезновение (появление) анимированного объекта. Что бы стало немного понятней, давайте рассмотрим следующий пример: анимацию появляющегося Текста.

Blender генерирует текст таким образом, что для него нельзя применить Эффект Построения, без предварительного преобразования в меш-объект. Даже после преобразования текста, Эффект Построения не работает с ним корректно. В этом случае лучше использовать текст, созданный во внешней программе Elefont.

Для начала создадим объект, который будет использовать Модификатор Построения. Для примера, я выбрал в качестве такого объекта - текст, созданный в программе Elefont. Для хорошего Эффекта Построения, обычно необходимо большое количество вершин меш-объекта. Если вы используете текст Elefont, то вам необходимо объединить все буквы текста в один меш объект. Выделите все буквы (удерживая Shift, кликайте по ним правой клавишей мышки), и нажмите "Ctrl J".

Теперь, не снимая выделения с объекта, перейдите к кнопкам Редактирования (F9). Во вкладке Modifiers нажмите Add Modifiers и выберите из списка модификаторов тип Build. У этого модификатора есть две опции настройки: Start (начальный кадр процесса построения) и Lenght (количество кадров, которые займет построение). Этими опциями Вы можете регулировать скорость этого эффекта. Кнопкой Randomized активизируется случайность появления граней при анимации.

Эффект Построения(Build) очень зависим от центральной точки объекта. Попробуйте изменить центр объекта (это обсуждалось в 3 главе) и вы заметите, что процесс построения будет происходить по-другому. Используйте это, для настройки эффекта.

Совет
Не беспокойтесь, что объект исчезает, когда вы устанавливаете для него модификатор Build. Вы можете видеть часть объекта находящуюся в текущем кадре анимации. Нажмите "Alt A" и Вы увидите анимацию появления граней вашего объекта.


Зеркальное отображение меш-объектов

В Блендере появился новый вид Модификатора - Mirror. В раних версиях Blender у вас была возможность дублировать, а затем зеркально отражать объекты (кнопка M), в Режиме Редактирования. Однако это совершенно другая функция.

Для демонстрации работы Модификатора Mirror возьмем обычный меш-объект куб. Подразделим (опция Subdivide) куб в Режиме Редактирования. Затем вытянем несколько вершин. Так же изменим позицию центральной точки (этот процесс описывался здесь).

Куб, до использования Модификатора Mirror

Куб, после активизации Модификатора. Так же активизирована кнопка Х (отражение по оси Х).

Опция - Merge Limit - Используйте для автоматического объединения близлежащих граней.


Эффект Волны

Модификатор Волн может быть использован для того, чтобы придать какому-нибуть объекту волнообразную форму. Давайте возьмем для примера объект, который имеет большое количество вершин - наш текст, созданный в программе Elefont. Так же добавьте меш-плоскость. Текст имеет большое количество вершин, а вот плоскость нет. Давайте это исправим: Выделите плоскость и перейдите в Режим Редактирования (кнопка Tab), затем выберите все вершины (кнопка A). В Меню Редактирования найдите кнопку "Subdivide" и нажмите на нее 3 раза. Покиньте Режим Редактирования. Результат должен быть как на рисунке ниже:

Теперь добавьте для каждого объекта Модификатор "Wave". Выделите объект, зайдите в Режим редактирования, во вкладке Modifiers нажмите кнопку Add Modifier и выберите из списка "Wave". Установите ваш курсор в 3D окне и нажмите "Alt A". Вы можете наблюдать анимацию, созданную Модификатором "Wave".

Основные настройки модификатора Волны это:

1) Cyclic - Циклическое движение волны.
2) кнопки X и Y - Движение волны по оси X и/или Y.
3) Width - Ширина волны.
4) Height - Высота волны.
5) Time sta - номер кадра, в котром начнется эффект волны.
6) Lifetime - количество кадров, в которых действует эффект.


Булевые Операции (добавление и вычисление)

Новинкой Blender 2.42 стал модификатор Boolean. Это другой способ создания Пересечения, Объединения и Разности объектов. Мы изучали Булевы операции в главе 3. Для добавления этого модификатора, выберите объект, который вы хотите модифицировать, перейдите в Меню Редактирования (F9) и в панели Modifiers выберите в списке Модификаторов тип Boolean.

В панели модификатора, введите имя второго объекта, выберите тип Булевой операции "Difference", "Union" или "Intersect", после этого нажмите кнопку "Apply". Меш объект должен деформироваться.

Использование Булевых операций - это лучший способ изменить форму меш-объекта с помощью другого меш-объекта. Если вам необходимо сделать отверстие в объекте - просто добавьте цилиндр и с помощью модификатора Булевых Операций вычтите его из объекта.


Практическое Занятие

Использование Модификаторов

Создайте новую сцену и сохраните ее как Modifiers.blend. Добавьте в сцену любые объекты на ваш вкус. Добавьте каждому объекту материал. Используйте следующие модификаторы:

- Subsurf
- Эффект Построения (Build)
- Зеркальное отображение Меш-объектов(Mirror)
- Эффект волны (Wave)
- Булевые операции (Boolean)

Сделайте анимацию (200 кадров) для ваших объектов.


Глава 13: Система Частиц и их Взаимодействие

С помощью систем частиц можно создавать разные визуальные эффекты. Такие как дым, огонь, взрывы, фейерверк, снег, искры, волосы, трава и многие другие. Любой меш-объект может служить как эмиттер частиц. При добавлении Системы Частиц объекту - грани объекта исчезают, а на вершинах объекта образуются частицы, которые Вы можете настраивать для получения желаемого эффекта. Вы можете управлять размером частиц (используя материал Hallo), а так же текстурой, цветом и прозрачностью. Вы можете заставить частицы отрываться от объекта в случайном или последовательном порядке. Так же можно настраивать количество частиц, их продолжительность жизни (начальный и конечный кадр), их направление (ось X, Y, Z). Кнопки управления Системой Частиц в новых версиях Blender поместили в отдельную вкладку (см. рис. ниже).

Настройка частиц

Давайте создадим сферу (UVSphere) и установим для нее количество сегментов и окружностей - 32. Покиньте режим редактирования (Tab) и перейдите к кнопкам Объекта (F7). Затем, нажмите на кнопку Physics Buttons(см рисунок). В панели Particles добавьте новую систему частиц, нажав на кнопку NEW. После этого должны появиться кнопки управления частицами как на рисунке ниже:

Интерфейс управления частицами сильно изменился по сравнению с предыдущими версиями Blender (раньше все кнопки управления были в одной секции). Теперь элементы управления частицами находятся в двух вкладках. Во вкладке Particles - настраивается внешний вид и свойства частиц, а во вкладке Particle Motion - движение частиц.

Нашим следующим шагом будет изучение параметров и настроек, доступных в панели управления частицами. В этой главе мы ознакомимся только с основами этой большой системы. Вы можете найти более подробное описание Системы Частиц, а так же уроки и примеры на сайте www.blender.org.

Панель Particle

В этой панели находятся кнопки управления внешним видом частиц. Давайте внимательней рассмотрим эту панель:

Delete - Удаление системы частиц

Amount - Количество частиц участвующих в анимации

Start и End - Начальный и конечный кадр действия эффекта

Life - Настройка продолжительности жизни частицы с момента ее появления на экране.

Verts/Faces(вершины/Грани) - расположение частиц на вершинах либо на гранях объекта.

Recalc All - Иногда, после внесения изменений в настройки частиц Вам необходимо нажать на эту кнопку для того, что бы обновить отображение частиц на экране.

Static - Используйте этот параметр если Вы не планируете анимировать частицы. Частицы будут сохранять свою позицию на протяжении всей анимации.

Mesh - отображается меш объект, являющийся эмиттером частиц;

Unborn - отображать частицы перед их "рождением";

Died - отображать частицы после их "смерти".

Vect - Каждой частице присваивается вектор (отрисовывается линия)

Vect Size - Настройка длины линии Вектора.

Панель Particle Motion

В этой панели находятся функции, которые вы можете использовать для анимации системы частиц. Какие из них нас интересуют в данный момент :

Normal - Настройка начальной скорости частиц.

Object - Если объект служащий эмиттером частиц анимируется, этим параметром вы можете настроить его начальную скорость.

Random - Это элемент случайности начальной скорости частиц.

Damping - Этой опцией настраивается амортизация движения частиц.

TexEmit - Использование Текстуры в качестве шаблона для излучения частиц.

RLife - Используйте этот параметр, если хотите внести некоторую случайность появления и исчезновения частиц.

Force X, Y, Z - Направление частиц по оси X, Y или Z.

Tex X, Y, Z - Направление частиц по оси X, Y или Z в зависимости от Текстуры.

Когда видишь эти настройки впервые - они кажутся сложными и непонятными. Однако с практикой все становится на свои места и приобретает смыл.

Вернемся к нашему примеру. Удостоверьтесь, что ваша сфера находится в Объектном режиме. Выделите ее и добавьте Эффект частиц. В панели Particle Motion установите значение Normal 0.2 или 0.3. Это обеспечит нормальну скорость движения частиц и заставит их как бы "вылетать" из сферы. Установите курсор в 3D окне и нажмите "Alt A" для просмотра анимации. Результат должен быть приблизительно такой как на рисунке ниже:

Частицы вылетают из объекта очень упорядоченно. Если вы захотите сделать с помощью частиц анимацию пламени или взрыва - Вам необходимо внести некоторую случайность в движение частиц. Что бы так сделать перейдите в режим редактирования сферы (кнопка Tab) и выберите все вершины (кнопка А). В Кнопках редактирования (панель Mesh Tools) нажмите на кнопку "Hash":

Это сделает движение наших частиц более случайным. Покиньте Режим редактирования (кнопка Tab) и вновь нажмите "Alt A" для просмотра анимации.


Влияние Материала на Систему Частиц

Частицы излучают свой собственный свет, это значит, что нет необходимости добавлять в сцену лампу что бы увидеть их. Однако вам необходимо добавить частицам материал, что бы контролировать их цвет, размер и прозрачность.

Если вы измените текущий кадр анимации на 50 и нажмете F12, то увидете приблизительно следующее:

Вы видите случайно вылетающие частицы без добавленного материала. Изменять размер частиц можно с помощью материала типа Halo. Так же можно настроить прозрачность частиц, ипользуя опцию Материала "Z Transp" и уровень прозрачности "Depth". Эффект прозрачности частиц идеален для анимации пламени, где используется множество объектов с частицами, материалы которых отличаются по цвету - благодаря этому пламя выглядит очень реалистичным.

Здесь, я добавил материал для сферы. Я так же активизировал кнопку "Halo", изменяя размер Halo (опция Halo Size) - размер частиц тоже будет изменяться. Еще я изменил цвет материала.

Вы должны настраивать размер ореола Halo, в зависимости о эффектов которые должны получится в итоге. К примеру для эффекта дыма необходимо маленькое количество частиц и большой размер ореола Halo, а так же настройки прозрачности ZTransparent и Alpha. А вот для огня требуется требуется большое количество частиц и маленький размер ореола Halo. Вы можете так же в настройках Halo настроить тип отображения ореола - в виде звезд, линий, колец и др. Читайте о настройках Материала типа Halo здесь!!?.


Взаимодействие частиц с объектами

Благодаря обширным нововведениям в области частиц, теперь они могут взаимодействовать с множеством других объектов, а так же с различными эффектами, например с эффектом ветра. Частицы могут отскакивать от других объектов, вести себя как искры или капли. Чтобы показать как работают эти взаимодействия частиц, мы создадим сцену со сферой и плоскостью, мы немного масштабируем плоскость и установим сферу над ней:

Далее, с выбранной сферой перейдите к Кнопкам Объекта и добавьте Систему Частиц. В панели Particle Motion установите значение Z Force -1.00. Это должно заставить вершины лететь строго вниз.

Установите свой курсор в 3D окно и нажмите "Alt A", для просмотра анимации. Вы можете видеть частицы вылетающие из сферы и падающие сквозь плоскость.

Теперь сделаем так, что бы частицы отскакивали от плоскости. Выберите плоскость и в Кнопках Объекта (смотрите рисунок) нажмите кнопку Deflection.

После этого нажмите "Alt A" для проигрывания анимации и... Вы увидите, что ничего не изменилось! Вы должны выбрать сферу и в панели Particles нажать на кнопку RecalcAll, для того чтобы пересчитать частицы.

После пересчета частиц, нажав "Alt A" Вы увидите изменения в анимации. Частицы теперь не пролетают сквозь плоскость, а отталкиваются от нее и летят вверх. Для того, что бы они отталкивались не так сильно установите значение амортизации Dampening 1.00 (вкладка Particle Motion).

Опять выберите сферу и нажмите в панели частиц кнопку RecalcAll, для того что бы пересчитать частицы. После этого частицы будут останавливать возле плоскости и прекращать свое движение. Экспериментируйте с этими настройками, что бы получить различные эффекты.

Экспериментируя с другими параметрами настроек частиц, такими как RLife (случайность в появлении и исчезновении частиц), Normal (начальная скорость частиц), Vect (вектор), Amount (общее число частиц), Life (продолжительность жизни частиц) и применив Материал типа Halo с опциями Lines и Stars, Вы можете имитировать искры отскакивающие от объекта.

Ветер

Теперь Blender позволят эффекту Ветра воздействовать на частицы. Чтобы создать эффект ветра, вам необходимо добавить объект, который будет служить основой для этого эффекта. Самый подходящий для этого объект - Объект Пустышка (Empty). Объект Пустышка не отображается при рендере изображения, он просто показывает направление осей X,Y,Z.

Этот объект применим еще в многих эффектах и мы его обсудим позже. Для добавления в сцену Пустышки установите 3D курсор в то место, куда бы вы хотели добавить эффект Ветра и нажмите Space >> Add >> Empty.

С выделенным объектом-Пустышка перейдите к Кнопкам Объекта (F7). Затем в панели Fields and Deflection выверите из списка "Wind".

Вы можете видеть некоторые настройки, с помощью которых можно контролировать эффект Ветра. Измените значение поля Strength(Сила) на 20.00. После этого, возле Пустышки появится несколько окружностей, представляющих собой поток ветра. Возможно Вам прийдется немного повернуть Пустышку(R), что бы поток был направлен в сторону частиц. Вращая Пустышку, Вы сможете пронаблюдать как действует эффект Ветра на частицы. Если этого не видно нажмите кнопку RecalcAll (в Кнопках Частиц) для перерасчета частиц сферы.


Образцы Настроек Частиц

Снег

Подразделите плоскость 3-4 раза (или более) и нажмите кнопку "Hash" в панели Mesh Tools. Снег должен медлено падать, поэтому установим небольшое отрицательное значение для поля Z force. Добавим плоскости материал типа Halo и настроем размер ореола. Используйте следующие настройки:

Amount: 1000
Sta frame: 1
End Frame: 100
Life: 75
Random Life: 0
Normal: 0
Force Z: -0.05
Vector: отключен

Облака

Создайте сферу (UVsphere) и измените ее форму используя Пропорциональное Редактирование (кнопка O в режиме Редактирования). Вытягивайте сферу пока она не станет похожа на облако. В панели Mesh Tools нажмите кнопку "Hash", а так же добавьте материал. В Кнопках Материала активизируйте кнопку ZTransp и установите значение прозрачности Alpha 0.1 или 0.2. Затем нажмите на кнопку Halo и установите размер ореола (Halo Size) 4.00. Для того, что бы облако смотрелось "пушистым", нажмите кнопку Static (в настройках частиц, которые Вы разумеется добавили для этого объекта). Смотрите дополнительные настройки частиц ниже:

Amount: 100
Sta frame: ---
End Frame: ---
Life: ---
RLife: 0
Normal: 0.03
Force : 0 для X, Y и Z
Vect: отключен

Огонь

Начните с добавления сферы, активируйте для нее кнопку "Hash"(панель Mesh Tools) и добавьте материал. Сделайте цвет материала красным или желтым. Активизируйте Halo и установите размер ореола (Halo Size) 1.2. Активизируйте движение частиц по оси Z, чтобы пламя поднималось в верх. Небольшое размер RLife внесет частицам пламени некоторую случайность. Для более реалистичного эффекта сделайте еще несколько таких сфер с частицами и установите для них красный, голубой и желтый цвет материалов. Так же добавьте прозрачность материалу частиц.

Amount: 500
Sta: 1
End: 100
Life: 25
RLife: 0.5
Normal: 0
Force Z: 0.3
Vect: отключен

Фейерверк

Начните с добавления сферы, активируйте для нее кнопку "Hash"(панель Mesh Tools) и добавьте материал. Сделайте цвет материала красным или желтым. Активизируйте Halo и установите размер ореола (Halo Size) 0.5. Можете эксперементировать с опциями отображения ореола Stars и Lines. Для хорошего финального результата вы должны уменьшить размер сферы. Все частицы "вспыхнут" в 1-2 кадре анимации. Установим большое значение случайности в появлении и исчезновении частиц RLife. Активизация вектора (Vect) даст нам интересный эффект. Смотрите остальные настройки ниже:

Amount: 500
Sta: 1
End: 2
Life: 30
RLife: 2
Normal: 0.1
Force Z: -0.3
Vect: включен
Vect.Size 1


Практическое Занятие

Система Частиц

Создайте новую сцену в Blender. Попробуйте сделать модель свечки с фитилем с помощью цилиндра. Создайте 3 сферы в области фитиля. Добавьте для каждой сферы систему частиц. Сделайте из этих сфер красное и желтое пламя, а так же струйку дыма. Используйте ZTransp и настраивайте Alpha для того что бы смешать красные и желтые части пламени, и имитировать поднимающуюся струйку дыма. Сделайте анимацию длиною 100 кадров и сохраните ее в формате AVI. Так же Вы можете добавлять другие объекты, что бы украсить сцену.


Глава 14: Связывание Объектов Методом Родитель-Потомок

Связь между объектами

За все время изучения мы узнали о том, как создавать и редактировать объекты, присваивать им текстуры и материалы, а так же как сделать рендер изображения или анимацию. Но как сделать так, что бы отдельные составные части модели робота, человека и др. взаимодействовали и зависели друг от друга, но при этом оставались отдельными меш-объектами? В этом случае нам пригодятся знания о связывании объектов методом Родитель-Потомок. Этот метод позволяет связывать объекты без фактического объединения. Это позволит индивидуальным частям передвигаться, но при этом зависеть от своего "Родительского" объекта.

Метод привязки "Родитель-Потомок" используется во всех программах анимации и заключается в том, что один из объектов становится "Родительским" для всех остальных. Если Родительский объект перемещается, вращается или изменяется в размере, остальные связанные с ним объекты (Потомки) делают тоже самое. С другой стороны, Потомственные объекты можно вращать, передвигать масштабировать при этом не изменяя Родительский объект. Приведу пример: рука - это Потомственный объект для предплечья, а предплечье - потомок плеча, а плечо - потомок туловища. Поэтому, если вращать или двигать предплечьем - рука будет следовать за ним, если плечо вращается, то за ним следуют предплечье и рука. А если двигается все туловище, все потомственные ему объекты (рука, предплечье, плечо) будут двигаться вместе с ним.

Для того чтобы связать объекты способом "Родитель-Потомок" в Blender'е, вам необходимо удерживая "Shift" выделить несколько объектов. Потомственный объект выбирается ПЕРВЫМ, затем выбирается Родительский объект. После того как объекты выбраны нажмите "Ctrl P" для того чтобы их связать. Как Вы можете видеть между центральными точками объектов появилась пунктирная линия. Эта линия отображает связь между Родительским и Потомственным объектом.

Совет
Для того, чтобы удалить связь между объектами, выберите оба объекта и нажмите "Alt P". Это поможет После этого, объекты уже не связаны друг с другом.

Давайте рассмотрим этот метод на примере. Попробуем из нескольких цилиндров сделать механические суставы робота и связать их методом "Родитель-Потомок". Запомните, центральная точка объекта (точка вращения) играет очень важную роль в этом методе. Установите центральную точку точку цилиндра в его конце. Для этого расположите 3D курсор в конце цилиндра, после перейдите к кнопкам Редактирования (F9) и в панели Mesh нажмите кнопку "Center Cursor". После этого дублируйте цилиндр несколько раз, с помощью "Shift D". Разместите копии цилиндра так, что бы начало каждого цилиндра было возле центральной точки предыдущего цилиндра (см. рисунок). Выберите первые два цилиндра и нажмите "Ctrl P" для создания связи. Затем цилиндр-потомок должен стать родительским для следующего цилиндра, поэтому, вы должны выбрать этот цилиндр вторым. Последовательно свяжите все цилиндры. Сделайте простую анимацию, чтобы проверить функциональность этого метода связи.

Совет
Вы можете сделать связь "Родитель-Потомок" между любыми объектами, включая камеру, лампы и пустышку.


Регулировка Центров Объектов (точек вращения)

Вы должны быть осторожны при редактировании объектов в режиме Редактирования. Потому, что когда Вы передвигаете вершины - центр объекта остается на месте. Для того, что бы изменить центральную точку объекта, в Объектном режиме установите свой 3D курсор в позицию нового центра объекта и нажмите кнопку Centre Cursor в Кнопках Редактирования объекта (F9).


Практическое Занятие

Создание Механических Суставов

Создайте новую сцену в Blender. Ваша задача: Создать механические суставы, используя метод "Родитель-Потомок", а затем их анимировать. Используйте для своей модели такие объекты как плоскость, куб, цилиндры и сферы. Добавьте материал каждому объекту, настройте хорошее освещение, а так же вид из камеры.

После того, как сцена будет готова, сделайте анимацию длиною 150 кадров. Покажите в анимации как двигаются механические суставы Вашей модели.

Дополнительное задание:

Попробуйте анимировать прыжок вашей механической модели над плоскость.


Глава 15: Работа с Ограничителями

Слежение за объектом

Иногда Вам необходимо "ограничить" движение объекта или заставить его "следить" за другими объектами сцены. В этом учебнике мы рассмотрим один из Ограничителей, с помощью которого можно заставить камеру следить за объектом. Этот ограничитель называется "Track To". Ограничители слежения используются в анимации и позволяют сэкономить много времени.

Давайте рассмотрим как работает ограничитель "Track To" на примере. Добавьте в сцену объект, за которым будет следить камера. Перейдите к его кнопкам редактирования (F9). Для дальней работы вам необходимо знать имя этого объекта. Вызовите информационное окошко с помощью кнопки "N", измените имя объекта на Actor для удобства.

Теперь выберите камеру, перейдите к кнопкам Объекта (F7). Найдите здесь вкладку Constraints, нажмите в ней кнопку Add Constraint и выберите из списка ограничителей "Track To". В панели опций Track To, найдите поле Target OB: Впишите в него имя нашего объекта, то есть Actor. После этого меду объектом и камерой появится пунктирная линия, обозначающая слежение камеры за объектом. Если Вы сейчас посмотрите в камеру - перед вами встанет одна проблема - Камера не видит объект! Чтобы решить эту проблему, нажмите кнопку To: -Z, а также Up: Y в панели Constraints. Вот и все! Теперь куда бы вы не передвигали объект - он всегда будет виден из камеры. Есть другой способ создания слежения камеры за объектом. Выберите камеру, затем объект и нажмите Ctrl T, в появившемся меню выберите тип "Track To Constraint".

Опции панели Constraints:

To: X,Y или Z и -X,-Y или -Z - оси, по которым происходит слежение. Обычно необходимо выбрать ось -Z

Influence - Степень слежения. Чем меньше значение этого поля, тем слабее слежение камеры за объектом.

Target - имя объекта слежения

Up - направление слежения обычно используется "Y"

Иногда в анимации используется прием слежения камеры за объектом Пустышкой. Это позволяет более динамически управлять фокусом камеры. Например Вы можете следить за объектом (возле которого находится пустышка), а затем изменить фокус (переместить пустышку). Так же поэкспериментируйте с параметром Influence.


Практическое Занятие

Слежение Камеры

Откройте сцену с механическим суставом, которую Вы сделали на прошлом практическом занятии. Настройте слежение камеры за любой частью вашей модели. На примере камера следит за головой робота (см. рисунок).

После того ка Вы настроите слежение камеры, сделайте анимацию длиною 150 кадров. Анимируйте движение вашего персонажа и камеры в любом направлении.


Путь Следования и Кривые

Иногда необходимо сделать так, что бы персонаж вашей анимации двигался определенно по заданному пути. К примеру, создавая анимацию летящего космического корабля, намного легче задать его движение по определенной линии, чем вставлять ключевые кадры на протяжении всей анимации. Пути и Кривые можно добавлять из меню Add и они могут использоваться не только для создания анимационных путей, а еще и как инструменты моделирования. С помощью кривых можно создавать поверхности, используя профиль и заданное направление кривой. В этой главе мы будем изучать оба способа использования кривых.

Путь Следования

Для начала давайте рассмотрим создание путей следования. Любая кривая (которую можно добавить из меню Add >> Curve) может стать путем следования, но для этого необходимо изменить некоторые ее настройки. Добавьте путь Space >> Add >> Curve >> Path.

После этого, на Вашем экране появится Путь(Path), находящийся в Режиме Редактирования. Вы можете изменить его форму, передвинув точки на его поверхности, а также добавить новые нажав кнопку Subdivide в Панели Редактирования (F9).

Существует несколько способов заставить камеру, объект или лампу следовать по определенному пути. Но сейчас, мы рассмотрим традиционный способ, с использованием связки Родитель-Потомок.

Выберите первым объект, затем путь (это Родительский объект). Нажмите "Ctrl P" для создания связи Родитель-Потомок. В появившемся меню вам предлагается две опции: "Normal Parent" и "Follow Path" - выберите "Normal Parent". Между двумя объектами должна появиться пунктирная линия. Нажмите "Alt A", для просмотра анимации движения объекта вдоль пути. Для того, что бы объект двигался точно по линии, просто переместите его ближе к ней. По умолчанию длина анимации пути составляет ровно 100 кадров, за которые объект-потомок проходит его полностью. Для того, что бы это исправить перейдем к кнопкам Редактирования (F9). Что мы видим:

Здесь находятся три основные опции для настройки объекта-потомка, который проходит вдоль пути. Это:

Path Length - Длина пути. Количество кадров, за которые объект пройдет весь путь.

Curve Path - Благодаря этой опции объект следует вдоль пути (по умолчанию выбрана).

Curve Follow - объект-потомок полностью повторят направление кривой.

Если Вы отрегулируете длину пути (Path Length) и запустите просмотр анимации "Alt-A", то вы увидите, что ничего не изменилось! Все дело в скрытой опции "Скорость", которую тяжело найти новичку в первое время. Выделите путь и измените тип одного из окон на IPO Редактор. Затем Вы должны установить тип IPO - Path. И удалить кривую Скорости. Смотрите пример ниже:

Иногда необходимо сделать так, что бы камера двигалась по определенному пути и была сфокусированная на каком-нибуть не объекте. Для этого Вам необходимо использовать опцию Curve Path, и отключить Curve Follow. Выберите камеру и затем объект на котором она должна бысть сфокусирована и нажмите "Ctrl T" и выберите опцию "TrackTo". После этого камера будет двигаться по определенному пути и будет сфокусированная на объекте.

Другие типы кривых из меню Add >> Curve, так же могут быть использованы как пути следования. Например если вы хотите сделать циклический путь, добавьте кривую Bezier Circle (Add >> Curve >> Bezier Circle). Однако эта кривая не будет автоматически путем следования, необходимо в Панели Редактирования активизировать кнопки "CurvePath" и "CurveFollow".


Использование Кривых для создания Поверхности объекта

Вы можете создать поверхность объекта с помощью Кривой. Давайте рассмотрим это на примере: Создадим первичную форму с помощью Bezier Circle и вытянем ее вдоль кривой типа Bezier Curve.

1. Добавьте в сцену кольцо-Бизье: Space >> Add >> Curves >> Bezier Circle и придайте ей какую-нибуть интересную форму. Вы можете добавлять дополнительные точки кривой с помощью W >> Subdivide.

2. Добавьте в сцену кривую-Бизье: Space >> Add >> Curves >> Bezier Curve и немного измените форму этой кривой.

3. В заключении выберите кривую-Бизье и перейдите к ее Кнопкам Редактирования (F9). Найдите здесь поле BevOb: и введите в него название кольца(у меня кольцо называется 'CurveCircle')

В результате профиль кольца-Бизье "выдавится" через весь путь.

Вы можете преобразовать новую форму кривой в меш-объект, для дальней работы с вершинами. Просто выделите кривую и нажмите "Alt C".


Практическое Занятие

Кривые и Путь

Создайте новую сцену в Blender и сохраните ее как Paths.blend. Сделайте так, что бы камера двигалась вдоль пути и была сфокусирована на объекте, который мы смоделировали с помощью кривой. Возможно, Вам потребуется изменить положение центральной точки объекта для того, чтобы камера правильно сфокусировалась на объекте (если вы не знаете как изменить центральную точку - читайте основы редактирования). Добавьте материал для всех объектов.

В финале сделайте анимацию длиной 100 кадров.


Глава 16: Арматуры (кости и скелет)

Использование арматуры для деформирования меш-объекта

Инструменты деформирования Blender прекрасно подойдут для анимирования большинства объектов, кроме тех случаев, когда вам необходимо сделать анимацию, например бегущего человека или сгибающегося от ветра дерева. Для такого рода деформирования объектов обычные модификаторы Blender не подходят. Нам необходимо использовать более сложные инструменты деформирования. В Blender'е есть два варианта сложной деформации объекта: деформирование объекта с помощью скелета(арматуры), а также с помощью Относительных ключей вершин (передвигая вершины меш-объекта в режиме редактирования).

В этой главе мы будем изучать первый способ сложной деформации, то есть деформацию с применением арматуры. Мы рассмотрим только основные принципы работы арматурными объектами. Более подробную информацию о использовании арматуры ищите на сайтах www.blender.org и www.elysiun.com.

Рассмотрим работу арматуры на примере. Создайте цилиндр (Add >> Mesh >> Cylinder), и установите значение для Verties 32. Затем, выделите верхний ряд вершин, с помощью бокс-выделения (клавиша B) и экструдируйте(клавиша Е) их вверх. Немного увеличьте масштаб вершин. Снова экструдируйте вершины и немного уменьшите их масштаб. Продолжайте экструдировать и масштабировать вершины, пока у вас не получится форма как на рисунке ниже:

Установите 3D курсор внизу цилиндра. Нажмите Space >> Add >> Armature. Как Вы можете заметить в том месте, где находился 3D курсор появилось новое звено арматуры (кость). Нажмите клавишу "G" для того, чтобы удлинить звено арматуры. Направьте курсор вверх и кликните левой клавишей мышки в той позиции, где должна заканчиваться кость. Теперь необходимо создать вторую кость, для этого выделите верхушку первой и нажмите кнопку "E", после этого из верхушки должна появиться вторая кость. Вы можете прекратить немедленное передвижение кости нажав кнопку "Esc". Чтобы изменить положение кости, кликните по маленькому шарику в верху(или внизу) кости и нажмите клавишу "G", переместите кость в нужную позицию. Вы сейчас находитесь в Режиме Редактирования арматуры, нажмите "Tab" для того, чтобы перейти к Объектному Режиму.

Далее нам необходимо связать арматуру и меш-объект способом Родитель-Потомок, где меш-объект будет выступать в роли Потомка, а арматура будет Родительским объектом. Удерживая кнопку "shift" выберите первым меш-объект, а затем арматуру. Нажмите "Ctrl P" для создания связи. В появившемся меню выберите опцию "Use Armature".

Затем вам предложиться несколько вариантов, каким образом будут двигаться вершины привязанные к костям арматуры. Выберите "Create From Closest Bone" , каждой кости будут присвоены вершины, находящиеся рядом с ними. Иногда этот способ создания группы вершин не очень хорошо работает, если группы вершин находятся слишком близко друг к другу, как например вершины пальцев руки. Вершины одного пальца могут присвоиться к арматуре другого пальца, в этом случае Вы не получите желаемого эффекта.

О том как решить эту проблему, мы поговорим позже. А сейчас пришло время испытать нашу модель!

При использовании скелетов или другие комплексных арматурных структур, Вам необходимо сделать следующее:

Объединить все части модели в один меш-объект. Это можно сделать, используя булевы операции (кнопка "W") или выделить объекты и нажать кнопку "J", для простого объединения. Перед объединением убедитесь, что для каждой части модели добавлен материал и текстура(если она подразумевается).

Анимирование модели с помощью арматуры (скелета):

Настало время анимировать нашу модель. Нам необходимо перейти в Режим Позы (Pose Mode). В меню режимов, выберите режим Pose Mode (см. рисунок). Это можно так же сделать с помощью "горячих клавиш" - "Ctrl Tab".

Кликните Правой клавишей мышки по одной из костей. Нажмите кнопку "R" для того, что бы вращать ее. Если в предыдущих шагах все было сделано верно, то меш будет вращаться вместе с костью. Устанавливайте ключевые кадры, для создания анимации.

Автоматическое добавление ключевого кадра для Арматурных объектов

Добавление ключевых кадров анимации для сложных арматурных объектов может оказаться весьма сложным занятием, если Вам необходимо в добавлять ключевые кадры поворотов для 20 костей арматуры. Поэтому очень удобно пользоваться опцией автоматического добавления ключевого кадра. Эту опцию можно активировать в окне Пользовательских Настроек. Наведите курсор мышки на верхнюю горизонтальную линию, разделяющую 3D окно и меню. Затем нажмите левую клавишу мышки и оттяните эту линию вниз. Выберите "Edit Methods" и нажмите кнопку "Action and Object" в пункте Auto Keyframing. После этого ключевые кадры буду добавляться после каждого изменения положения костей арматуры. Не забудьте отключить эту опцию после того, как вы закончите работу с анимацией арматурного объекта, иначе могут возникнуть некоторые проблемы.


Создание Групп Вершин

Как упоминалось раньше, иногда когда группы вершин разных костей находятся слишком близко друг другу, Blender может автоматически объединить эти вершины в одну группу. Для таких случаев Вам необходимо вручную указать группу вершин. После того как Вы создадите меш и арматуру, свяжите их методом Родитель-Потомок (Ctrl P >> Use Armature) выберите опцию "Don't Create Groups" (не создавать группу вершин). После этого арматура и меш-объект будут связанны, однако костям не будут присвоены группы вершин. Опция "Name Groups" создаст необходимые группы, однако не включит в них вершины. Эта опция наверно лучше чем "Don't Create Groups", потому что компьютер создаст более точные названия групп. Однако сейчас мы рассмотрим создание и присвоение имен для наших собственных групп вершин.

Для этого примера я создал меш-объект, который назвал Finger(палец). Для создания второго пальца я дублировал первый палец и его арматуру. Затем я объединил ("Ctrl J") две арматуры, а затем два меша.

Я связал арматуру и меш-объект способом Родитель-Потомок (Ctrl P) и выбрал опцию "Don't Create Groups" (не создавать группу).

Теперь необходимо узнать название каждой кости, что бы присвоить им вершины меш-объекта. Выберите арматуру, затем перейдите к кнопкам редактирования, найдите кнопку "Draw Name". Нажмите на нее, после этого вы увидите, что возле каждой кости появилось ее название. Вероятнее всего у костей такие имена: Bone, Bone.001, Bone.002 и т.п.(см. рисунок)

Выберите меш-объект и перейдите в Режим Редактирования(кнопка Tab). В кнопках Редактирования обратите внимание на панель Vertex Groups, здесь вы можете создать группу вершин объекта(отображается только в Режиме Редактирования). Нажмите кнопку "New", чтобы добавить новую группу вершин для кости. Мы должны присвоить эту группу для кости Bone (нижняя левая кость нашей модели). Впишите в поле "Group" название этой кости, тоесть Bone. Помните, что для каждой кости необходима индивидуальная группа вершин и название группы должно соответствовать кости (т.е. Bone.001, Bone.002).

Теперь нам необходимо выбрать вершины, которые должны перемещаться вместе с соответствующей им костью. После того, как вы выберите вершины нажмите кнопку "Assign". после этого группа вершин присвоилась к кости. Сделайте это для всех костей, выйдите из Режима Редактирования и выберите арматуру. Нажмите "Crtl Tab" для входа в Режим Позы, где вы можете тестировать работу арматуры. Если вым понадобится внести изменения в какую-нибуть группу, вы можете вернуться к Режиму редактирования меш-объекта и откорректировать настройки.

Помните я упоминал опцию "Name Groups", которая доступна после связки арматуры и меш-объекта? Эта опция автоматически создает группы с правильными именами.


Использование IK (Inverse Kinomatics)

Инверсная кинематика (далее по тексту IK) используется, тогда когда необходимо манипулировать всем скелетом, просто передвигая (кнопка G) конечную кость арматуры, все кости этой цепи будут двигаться вместе с ней. Инверсная кинематика постоянно находится в разработке и имеет множество опций. Посетите www.blender.org для получения дополнительной информации.

Рассмотрим работу IK на примере, из вида сверху добавьте цилиндр. Перейдите в вид спереди, затем экструдируйте и масштабируйте вершины объекта несколько раз, что бы результат был как на рисунке ниже:

Затем расположите 3D курсор в низу цилиндра и добавьте арматуру. Используйте "G" для того, что бы установить кость в место первого сгиба. Нажмите "E" и экструдируйте вторую кость, установите ее в область второго сгиба. Повторите эту процедуру еще два раза, в итоге у вас арматура должна состоять из четырех костей.

Свяжите Меш-объект и арматуру способом Родитель-Потомок с помошью "Crtl P" и выберите опцию создания групп вершин "Create From Closest Bones".

Перейдите в Режим Позы и вращайте кости, что бы удостовериться, что группы вершин были назначены правильно.

Если все группы были назначены верно, тогда вернитесь в объектный режим. В Кнопках Редактирования найдите кнопку Auto IK и нажмите ее. Для того, что бы увидеть как работает IK, вернитесь в Режим позы, выберите верхнюю кость и передвигайте ее (кнопка "G"). Все кости, должны в равной степени деформировать объект, относительно верхней кости. Это отличная функция, при анимировании движения пальцев.

Дополнительные Параметры настройки Арматуры:

Вот еще несколько опций, которые можно использовать для облегчения работы с арматурой:

X-Ray: С помощью этой опции, Вы можете видеть арматуру, когда объект находится в режиме затемнения (кнопка Z).

Display Options: Различные режимы отображения арматуры

Hinge: Используется для того, чтобы предотвратить вращение костей, когда вращается родительская(главная) кость.


Практическое Занятие

Создание Скелета

Создайте новую сцену в Blender и сохраните ее как Hand.blend. Добавьте UV Сферу для руки и цилиндр для пальца. Используйте экструдирование для того, чтобы удлинить палец. Дублируйте палец, чтобы сделать в общей сложности 3 пальца. Придайте сфере форму руки, используете для этого Режим Пропорционального Редактирования (кнопка "O"). Объедините все меш-объекты в один.

Создайте 2-х костную арматуру для каждого пальца, а затем объедините их в одну арматуру. Свяжите меш-объект и арматуру способом Родитель-потомок и создайте группы вершин (если хотите активизируйте опцию автоматического добавления ключевого кадра).

Добавьте материал меш-объекту. Настройте хорошее освещение и создайте анимацию, длиной в 100 кадров.

Дополнительное задание:

Попытайтесь использовать арматуру для анимации других объектов, например несложного туловища.


Глава 17: Относительные Клавиши Вершин

Создание Относительных Ключей Вершин

Мы рассмотрели деформацию меш-объекта с помощью арматуры, однако существует другой способ изменения формы объекта, который удобней использовать при анимации движения губ, моргании глаз и т.п. Это конечно можно сделать и арматурой, но куда удобней регулировать моргание глаза с помощью специального бегунка. Смотрите пример ниже:

Деформация меш-объекта с помощью слайдеров в Окне Редактора Действий может оказаться довольно сложным процессом, поскольку вам необходимо сформировывать форму меш-объекта в Режиме Редактирования, передвигая вершины. После некоторой практики, это может стать полезным инструментом, который позволит вам быстро и качественно делать анимации на профессиональном уровне. Как вы можете видеть на рисунке-примере выше, существует несколько слайдеров, которые вызывают различные действия. Комбинируя их вы можете разнообразить мимику вашего персонажа.

Первым шагом в создании Относительных Клавиш Вершин (ОКВ) является работа с вершинами меш-объекта. Рассмотрим на примере, создайте UV сферу, с 32 сегментами и окружностями. Разделите 3D окно на 2 части и измените тип правого окна на Action Editor Window. В этом окне ключевые кадры вашей анимации будут отображаться как отметки на графике. Ключевые кадры здесь можно дублировать и передвигать. Когда мы создадим ОКВ, она отобразится в панельке слайдеров.

Вернемся к левому 3D окну и начнем создавать ОКВ. В отличие от обычной анимации, в которой вам необходимо изменять форму (позицию и т.п) объекта в различных ключевых кадрах анимации, мы создадим все слайдеры деформации объекта в одном кадре. После того как все слайдеры будут созданы, в Окне Редактора Действий мы изменим их положение в анимации. Перейдите с сферой в Объектный Режим. Нажмите кнопку "I" и выберите опцию Mesh. В раних версиях Blender, необходимо еще выбрать одну из двух опций: Relative Keys либо Absolute Keys. Выберите опцию Relative Keys. В версия Blender выше 2.41 Относительные Клавиши Вершин создаются автоматически.


Использование Слайдеров Редактора Действий

После того как вы создадите ОКВ, в окне Редактора Действий добавиться новый Слайдер. Однако в списке слайдеров еще нет ни одного ключа.

Направьте свой курсор в 3D окно и снова нажмите кнопку "I", а затем выберите опцию "Mesh". В списке слайдеров появиться новый ключ ("Key 1"). Теперь необходимо назначить определенное действие этому ключу. Перейдите в Режим Редактирования сферы (кнопка "Tab") и измените положение вершин на свой вкус. Когда Вы выйдите из Режима Редактирования, деформации меш-объекта будут присвоены слайдеру "Key 1". Создайте еще один слайдер, но перед этим выйдите из Режима Редактирования (кнопка Tab), затем вновь войдите в режим редактирования и измените положение вершин. Когда вы выйдите из режима редактирования, новые модификации будут присвоены второму ключу из списка слайдеров. Смотрите пример:

С помощью этих бегунков, вы можете контролировать деформацию объекта в процентах. При регулировке бегунка, на графике анимации добавляется ключ в текущий кадр. Перейдите в следующий кадр, который необходимо сделать ключевым и измените позицию бегунка. Нет необходимости нажимать кнопку "I" для добавления ключа в кадр анимации.

Чтобы изменить название ключа, направьте свой курсор на ключ, название которого Вы хотите изменить и нажмите кнопку "N" (или просто кликните по нему). В появившемся окошке измените название ключа. Так же вы можете настроить минимум (min:) и максимум (max:) для ключа.


Новая Панель Создания ОКВ в Blender 2.40

В версии Blender 2.40 появилась новая возможность создания Относительных Ключей Вершин в Панели Редактирования. Вместо того, что бы вставлять ключ с помощью кнопки "I", можно сделать следующее:

Выбрать меш-объект, затем в Кнопках Редактирования(F9) найти панель Shapes. Нажмите на кнопку "Add Shape Key". Произойдет тоже самое, что и при нажатии "I" первый раз: создастся слайдер с пустым списком ключей.

Снова нажмите на кнопку "Add Shape Key". После этого в списке появиться первый ключ. Зайдите в режим Редактирования и измените положение вершин меш-объекта. После того как Вы придадите объекту необходимую форму выйдите из режима редактирования (кнопка Tab), объект примет свою прежнюю форму и ключу слайдера будет назначена определенная деформация вершин. Такая же информация о ключах слайдера находится в окне Редактора Действий.

Таким образом эта панель работает так же как меню добавления ключа "I", которое мы обсуждали раньше. Это альтернативный способ добавления Относительных Ключей Вершин.


Практическое Занятие

Оносительные Ключи Вершин

Создайте новую сцену в Blender и сохраните ее как RVK.blend. Создайте несложную модель лица (или просто сферу) и с помощью Относительных Ключей Вершин создате анимацию мимики лица (или деформации сферы). Добавьте материал меш-объекту и настройте хорошее освещение. Сделайте анимацию состоящуюю из 150 кадров и сохраните ее в формате AVI.


Глава 18: Система мягких тел (Soft Bodies)

Создание ткани и эффекта волны

Одна из наиболее лучших и полезных новинок Blender'a - это Система мягких тел (Soft Bodies). Система мягких тел используется при моделировании одежды, воды и др. Меш-объект которому назначена Система мягких тел могут быть деформирован другими объектами (например деформирование воды от плывущей по ней лодки). Настройки Системы мягких тел (Soft Body) и Системы Имитации Жидкости (Fluid Simulation) находятся в панели Physics:

Давайте попробуем создать простую анимацию плоскости с применением Системы мягких тел, которая в итоге будет взаимодействовать со сферой как ткань. Создайте плоскость и расположите ее над сферой как показано на рисунке ниже:

Перейдите в Режим Редактирования плоскости и подразделите плоскость 4-5 раз. Для хорошей работы Системы мягких тел необходимо достаточно много вершин.

Выделите все вершины плоскости и в Панели Редактирования создайте новую группу вершин. Не изменяйте название группы. Установите значение для Weight (вес) 0 и нажмите кнопку Assign. Эта опция сделает вершины плоскости невесомыми и они смогут падать вниз как ткань.

Теперь выделите две крайние вершины как показано на рисунке. Установите значение для Weight 1 и нажмите кнопку Assign. Эти вершины останутся закрепленными (они не будут падать).

Выйдите из Режима Редактирования. В Панели объекта(F9) найдите вкладку Physics(см. рисунок) и нажмите на кнопку Enable, тем самым вы добавите Систему мягких тел плоскости.

Теперь нам необходимо настроить несколько опций, для того чтобы увидеть анимацию. Для начала установите значение Grav: 9.800 (настройка гравитации), затем кликните по иконке с двумя стрелочками возле кнопки "Use Goal" и выберите в появившемся списке группу вершин - Group.

После этого вы можете увидеть как работает Система мягких тел! Направьте свой курсор в 3D окно и нажмите "Alt A" для просмотра анимации. Плоскость падает на сферу и проваливается скозь нее, не совсем то что нам нужно, но это еще не финал.

Теперь необходимо ткань более "прочной", чтобы она не теряла своей формы. Под кнопкой "Use Edge" вы можете видеть поле, которое называется "E Stiff", эта опция регулирует "эластичность" вершин. Если установить значение этого поля 0, то форма ткани при падении будет вытягиваться бесконечно (попробуйте так сделать). В нашем случае необходимо установить значение для поля "E Stiff" 0.95, что бы форма ткани не очень растягивалась. Просмотрите анимацию еще раз (Alt A). Теперь, пришло время настроить взаимодействия ткани и сферы.

Выберите сферу и нажмите на кнопку Deflection в панели Fields and Deflections (см.рисунок). Установите значение Damping 1 (в поле Soft Body).

После этого плоскость будет взаимодействовать со сферой как показано на примере, однако плоскость еще немного проходит сквозь сферу... Что бы это исправить, подразделите плоскость в Режиме Редактирования еще несколько раз и/или используйте модификатор Subsurf. Экспериментируйте с этими настройками, чтобы получить хороший результат. Чтобы ускорить время на обработку анимации можно используйте сферу с меньшим количеством вершин.

Мы можем ускорить процесс отрисовки анимации ткани, используя функцию "Bake" (Выпечка). Для ее активизации выберите плоскость, затем нажмите кнопку "Bake Settings" в панели Soft Body. Настройте начальный и конечный кадр "выпекания" с помощью опций Start и End и нажмите на кнопку "Bake". После того, как закончится обработка (выпечка) кадров анимации, нажмите "Alt A" для ее просмотра. Анимация теперь обрисовывается значительно быстрее. Если вы хотите внести поправки в настройки системы мягких тел, нажмите на кнопку "Free Bake", измените настройки и затем вновь нажмите на кнопку "Bake".


Использование Сил для манипуляции мягкими телами

Помимо взаимодействия мягких тел с другими объектами Вы можете воздействовать на них различными эффектами, например эффектом ветра.

Чтобы продемонстрировать этот процесс, я удалил сферу из сцены, для повышения скорости отрисовки анимации. Затем я добавил Пустышку и расположил ее слева от плоскости. Мы будем использовать Пустышку в качестве источника ветра. Как Вы помните, объект-Пустышка не отображается при рендере, поэтому его очень удобно использовать для имитации ветра.

Выделите пустышку и перейдите в панель Fields and Deflection, выберите из списка "Wind" (см. рисунок). Установите значение для Strength (мощность ветра) около 25.

Если ветряные кольца направленны не на плоскость, поверните их с помощью "R" к плоскости. Нажмите "Alt A" для просмотра анимации.

Ветер настолько сильный, что просто "сдувает" плоскость. Попробуйте уменьшить значение мощности ветра (Strength) до 0.2 и снова просмотрите анимацию.

Теперь эффект смотриться гораздо лучше. Если сделать достаточно длинную анимацию можно заметить, что плоскость просто замедляет свое движение возле источника ветра(пустышки) и отклоняется вправо. Чтобы сделать порывы ветра более случайными нам необходимо анимировать Мощность ветра либо добавлять ключевые кадры для Пустышки, изменяя его позицию. Чтобы добавить ключи анимации для Мощности, Вам необходимо создать кривую к окне IPO. В настоящее время Blender не позволяет добавлять ключевые кадры для мощности ветра с помощью кнопки "I".

Создание Кривой для Мощности ветра в Окне IPO

Разделите 3D окно на две части и измените тип одного из окон на Редактор IPO Кривых. Выберите Пустышку найдите дорожку FStrength (с правой стороны окна IPO) и кликните по ней. Чтобы добавить точки кривой, удерживая кнопку Ctrl левой клавишей мышки кликайте по желаемым отметкам графика (кадр 1 - значение мощности 0, кадр 100 - значение мощности более 2), смотрите рисунок ниже. Измените тип кривой на Линейный (кнопка T >> Linear) и добавьте много точек кривой с помощью Ctrl-ЛВМ. Просмотрите анимацию еще раз с "Alt A".

Система мягких тел может быть использована для многих эффектов. В Blender'e, так же появились некоторые возможности имитации жидкости с помощью функции Fluid Simulation. Однако я не буду описывать эту возможность Блендера из-за того, что эта функция пока несет эксперементальный характер. Вы можете прочитать о разработках Blender на сайте www.blender.org.


Практическое Занятие

Создание Флага

Создайте новую сцену в Blender и сохраните ее как Flag.blend. Добавьте цилиндр и сферу для флагштока и плоскость для флага. Выделите все вершины плоскости, подразделите их несколько раз и создайте группу вершин, установите для всех вершин нулевой вес (за исключением двух вершин возле флагштока, для этих вершин необходимо настроить значение веса 1). Добавьте плоскости Систему Мягких Тел, так же добавьте эффект ветра для Пустышки. Анимируйте мощность ветра, с помощью IPO кривой FStrengt. Добавьте материалы и текстуры всем объектам.


Глава 19: Создание Пружин, Резьбы и Шестеренок

Дублирование Меш-объектов для создания Пружин и Резьбы

В Blender есть множество функций, присущие всем 3D программам, такие как экструдирование вдоль пути, логические вычитания и прибавления меш-объектов(Булевы операции), но сейчас мы будем изучать функции создания поверхности при вращении. Настройки этих функций находятся в Кнопках Редактирования, они отображаются только в Режиме Редактирования меш-объекта. Давайте их рассмотрим:

Вращение с Дублированием (Spin Dup)

Spin Dup - дублирует группу вершин относительно положения 3D курсора. На примере, который вы можете видеть ниже, я использовал деформированный куб, для того чтобы сделать модель шестеренки.

Для начала, добавьте в сцену куб, перейдите с ним в Режим Редактирования и придайте ему форму зубца шестеренки. Затем, выберите все вершины и установите следующие настройки:

• Degr (вращение в градусах)- установите 360, для полной окружности.

• Steps - количество копий объекта. Установите здесь желаемое количество зубцов шестеренки.

• Turns (Обороты) - общее количество оборотов. Установите значение 1, для одного полного оборота.

Установите 3D курсор в предполагаемый центр шестеренки, выделите все вершины и нажмите на кнопку "Spin Dup". После этого вокруг 3D курсора создадутся копии зубца шестеренки. Возможно необходимо будет отрегулировать размер исходного зубца и количество копий, для хорошего результата. Для отмены команды "Spin Dup" используйте "U", для возврата в предыдущую позицию. Для того, что бы шестеренка смотрелась более реалистичной, добавьте грани(выделите 4 вершины и нажмите F) между зубцами, так же можно создать цилиндр и с помощью Булевых операций заполнить поверхность середины шестеренки.

Вращение (Spin)

Команда "Spin" работает почти так же как "Spin Dup", за исключением того, что при вращении не создаются копии вершин меш-объекта, а происходит экструдирование. Добавьте плоскость или круг, в Режиме Редактирования придайте объекту какую нибуть интересную форму. Расположите 3D курсор в предполагаемом центре будущего экструдированного объекта. Установите значение для "Degr" 360 и Steps 30. Выберите все вершины, перейдите в вид спереди и нажмите кнопку "Spin". Весь этот процесс демонстрируют изображения ниже:

Форма окружности изменена в Режиме Редактирования. 3D курсор расположен слева от окружности в предполагаемом центре объекта.

Так выглядит объект после активизации команды вращения "Spin".

Финальная модель.


Создаем спиральную Поверхность

Наиболее сложный из трех инструментов - Screw (Винт). С помощью этой команды можно сделать спиральную поверхность объекта. Используется для создания пружин, болтов, шурупов и т.п. Эта функция запускается только из вида спереди (NumPad 1). Давайте же рассмотрим работу Screw на примере, перейдите в вид Спереди(NumPad 1).

Для того, что бы создать спираль, вам необходимо сначала добавить меш-объект Окружность(Circle) из вида спереди. Как и для других инструментов вращения вам необходимо поместить 3D курсор в предполагаемом центре будущей спирали (см. рисунок). Теперь, необходимо создать линию вершин, которая будет представлять собой ось вращения спирали, так же важно растояние между окружностью и осью, так как от этого зависит плотность завитков спирали. Для создания линии вершин добавьте плоскость и удалите 2 ее вершины. Сделайте линию вершин такого размера, какой должен быть у одного завитка спирали. Объедините окружность и линию в один меш объект, выделив их и нажав "Ctrl J". Расположите линию в центре будущей спирали (тоесть возле 3D курсора). Смотрите пример ниже:

Установите следующие настройки:

• Degrees - 360
• Steps - 16 (или больше)
• Turns - количество желаемых завитков (я установил 8)

Выберите все вершины (в том числе и вершины линии) и нажмите кнопку Screw. После этого из окружности и оси должна сформироваться спираль. Если необходимо что нибуть подкорректировать нажмите "U", для отмены команды Screw. Финальная модель:

Как вы можете заметить в центре спирали находиться тоненькая полосочка вершин, она образовалась из той линии вершин, которую мы создали для регулировки размера завитков. Что бы удалить ее, перейдите в вид сверху, выделите эти "лишние" вершины и нажмите кнопку "Delete". После этого спираль будет выглядеть лучше.

Другие Формы Спирали:

Вот примеры использования Screw с другими формами меш-объектов:

Для Винтовой резьбы в качестве профиля была использована подразделенная плоскость, размер вспомогательной линии в 2 раза больше меньшей стороны профиля. В центр получившейся спирали был добавлен цилиндр, для того, что бы придать винту более законченный вид.

-------

Спираль для шурупа и болта была создана с помощью треугольника, который можно легко получить немного модифицировав плоскость, вспомогательная линия вершин по размеру должна совпадать с основанием треугольника. После того, как была создана спираль, выделите самые нижние вершины и активизируйте Режим пропорционального редактирования ("O"). Масштабируйте эти вершины, удерживая Ctrl пока они не сойдутся в одну точку. Экспериментируйте, для получения интересных эффектов.


Практическое Занятие

Моделирование Шестеренок

Создайте шестеренку и спиральный винт, используя те знания которые Вы получили, прочитав эту главу. Добавьте материалы, текстуры объектам, а так же настройте хорошее освещение. Сделайте анимацию вращающихся шестеренок, состоящую из 200 кадров. Не забывайте о опции Extend Mode в окне IPO кривых. Вам достаточно будет сделать небольшой отрезок анимации вращения, а все остальное сделает компьютер :)


Глава 20: Основы Игрового Движка - Game Engine (анимация в реальном времени)

Вы убедились в том, что Blender достаточно мощная программа рендеринга и анимации, но что же отличает ее от других 3D редакторов? Основное отличие заключается в том, что у Blender'е есть функция интегрированной анимации реального времени (Game Engine).Программа объединяет движение в реальном времени с физикой и логическими блоками. Например, вы можете настроить "тяжесть" в настройках Окружения, добавить трение и различные эффекты для материалов объектов, превращать объекты сцены в "актеров", затем сделать так, чтобы они реагировали на другие объекты сцены.

Вы можете создать игры, котрые могут быть очень профессиональными, так же можно создавать прогулки по различным архитектурным объектам в реальном времени. Самое удивительное - то, что все это можно сделать без навыков программирования. Существуют и другие распространяемые программы для создания игр, однако для того, что бы работать с ними необходимы некоторые навыки программирования. Умение программировать на языке Python может очень пригодиться при работе с созданием игр в Blender, однако это не обязательно.

Эта глава не является описанием всех возможностей игрового движка Blender(Game Engine). Мы рассмотрим только основы создания игр: текстурирование моделей и интерфейс логических блоков. Более подробную информацию, туториалы и примеры игр Вы всегда можете найти на сайте www.blender.org.

Настройка Physics Engine (Движка Физических свойств)

Для того, чтобы использовать игровой движок, необходимо совершить некоторые настройки. Перейдите к кнопкам Редактирования Окружения. Во вкладке Mist/Stars/Physics вы можете настроить движок. Sumo - используется для создания игр, а Bullet - для анимации IPO кривых. Также здесь можно настроить гравитацию с помощью бегунка Gravity.


Использование Логических Блоков

Создайте сцену и добавьте в нее плоскость и сферу. Расположите сферу над плоскостью. Войдите в режим Редактирования сферы и вытяните одну вершину, чтобы сформировать нос. Это позволит нам ориентироваться куда направлена сфера при передвижении. Добавьте материал каждому объекту и не утруждайте себя изменением каких-либо параметров материала. Обычные настройки материалов и текстур не работают в игровом движке, поскольку система расчетов была бы слишком сложной. Мы добавим текстуру объектам другим способом. Добавьте материалам объектов физические свойства:

DYN (Динамика) - настраивается в кнопках редактирования материала

Выберите сферу и перейдите к Кнопкам Игры (маленькая фиолетовая кнопка [image]). Это интерфейс настройки игры:

• Actor (Актер) - превращает объект в актера игры.

• Add Property (Добавить свойства) - используйте если хотите, чтобы что-то изменялось в вашей сцене.

• Sensors (Сенсоры), Controllers(Контролеры) и Actuators(Приводы)- это "мозг" игрового движка. Этими командами задается основа игры.

Давайте сделаем нашу сферу "актером" игры. Кликните по кнопке Actor, после этого нажмите кнопку Dynamic (находится с правой стороны от Actor). Давайте установим следующие настройки:

• Damp (торможение): Я установил значение для этой опции 0.4

• Actor Size (Размер Актера) - Как вы можете заметить вокруг сферы появился пунктирный круг - это размер актера, вы можете изменить его с помощью этой опции.

• Mass (Масса) - настраивает массу вашего актера :)

• RotDamp - торможение при вращении объекта. Я установил значение для этого поля 0.8.

Поместите свой курсор в 3D окно и нажмите кнопку "P" для проигрывания анимации реального времени. Если сфера находилась над плоскость - она упадет на нее, это показатель того, что сфера является "актером" игровой анимации. Нажмите на кнопки "Add" в панелях Sensors, Controllers и Actuators. Нажимая левой клавишей мышки по спискам, имеющимся в каждом блоке Вы можете изменять их тип. Измените тип сенсора Always (Во вкладке Sensors) на тип Keyboard (Клавиатуру). Затем, соедините все блоки(см. рисунок).

Как только вы установите тип сенсора Клавиатура, перед вами появятся новые опции. Кликните по полю Key, затем нажмите кнопку на клавиатуре, для которой вы хотите назначить какое нибуть действие в игре. В этом примере я нажал кнопку "Стрелочка вверх". Мы назначим этой кнопке движение веред, в игре нажав на кнопку "Стрелочка вверх" сфера будет двигаться вперед.

А сейчас давайте назначим определенное действие для кнопки. Как вы можете видеть блок Actuators состоит из трех колонок (при выбранном типе Motion). Эти колонки представляют собой настройки движения по осям X, Y и Z. Чтобы изменить значение какого-нибуть поля, удерживайте "Shift" и кликайте по нужному полю. В блоке Force(Сила) измените значение Y (второе поле) на 10. Вы можете поэксперементировать со значениями этих полей, что бы настроить желаемое направление движения. Если сфера движется в обратном направлении - попробуйте использовать негативное значение для Force Y.

Теперь, добавьте еще по одному логическому блоку во вкладках Sensors, Controllers и Actuators., соедините их и настройте действие для кнопки "Стрелочка вниз", чтобы при нажатии на эту кнопку сфера двигалась вниз. Таким же образом назначьте действия кнопкам "Стрелочка вправо"(движение направо) и "Стрелочка влево"(движение сферы влево).


Использование Материалов

Каркасное отображение объектов прекрасно подходит для тестов движения, однако для игры необходимо добавить объектам красивые текстуры. Нажмите "Alt Z" для того, что бы перейти в текстурный режим отображения объектов. Однако, если вы сейчас нажмете "P", для просмотра игры - объекты будут выглядеть ужасно. Необходимо добавить UV Текстуру.

Вы можете просто закрасить меш-объект, для этого выберите сферу и нажмите кнопку "F", для того чтобы выбрать грани сферы для применения текстуры. В этом режиме вы можете выделять индивидуальные грани, а затем накладывать на них текстуры(но об этом позже). Выделите все грани (кнопка A) и перейдите в Режим Vertex Paint (Окрашивание вершин):

Нажав F9 вы увидите различные настройки этого режима. С помощью бегунков R, G, B настройте цвет, которым Вы хотите закрасить сферу. После этого нажмите кнопку "Set Vert Col" для присвоения цвета и нажмите "F" для выхода из режима выбора граней. Теперь если вы нажмете "P" для проигрывания, вы увидите что сфера приобрела цвет, однако она смотриться плоской и без затемнений. Давайте это исправим. Для начала убедитесь, что у вас в сцене достаточное количество ламп. Затем выберите сферу и нажмите "F", найдите кнопку "Light" и активизируйте ее. После нажатия на кнопку "Light" необходимо так же нажать на "Copy DrawMode". Выйдите из режима выбора граней и запустите игру с помощью кнопки "P". Теперь сфера смотрится значительно лучше.

Вот еще несколько опций закрашивания:

• Vertex Paint (Окрашивание)- С помощью специальной "воздушной" кисточки можно окрашивать объект.

• Настройки Цвета R,G,B - здесь можно изменять цвет.

• Opacity и Size - Настройки прозрачности и размера кисточки

• Set VertCol - нажмите на эту кнопку для того, что бы применить цвет

• Copy DrawMode - нажмите на эту кнопку, если вы внесли изменения в настройки и хотите их применить

• Кнопка Collision - если ее отключить, актеры будут проходить сквозь объекты.

• Кнопка Light - делает объекты чувствительными к освещению.

• Twoside - расположение материала с двух сторон грани.

Теперь, после того как мы научились окрашивать объекты, добавлять эффекты освещенности давайте рассмотрим метод текстурирования с помощью UV опций. Разделите ваше 3D окно на 2 части. Измените тип одного из окон на UV/Image Editor (Редактор UV Изображений). В меню Image нажмите на Open и загрузите изображение, которое вы хотите использовать в качестве текстуры. Теперь выберите сферу, нажмите "F" и выберите все грани (кнопка A). В окне Редактора UV Изображений нажмите на кнопку с двумя стрелочками и выберите загруженную вами текстуру.

Примечание: Если вы хотите использовать текстуру, вам необходимо изменить цвет сферы снова на белый и отключить кнопку Light опциях закрашивания. После того, как вы нажмете "P" ваша сфера будет выглядеть примерно так же как и моя:

Выглядит неплохо, однако вам наверно хотелось бы наложить текстуру на каждую грань индивидуально. Поместите свой курсор в 3D окно и нажмите кнопку "U" для вызова опций UV Маппинга.

Выберите опцию Cube и установите размер 1.00. В окне Редактора UV изображений Вы можете видеть как вершины расположились на текстуре. Поместите свой курсор в это окно и нажмите кнопку "A" для того, что бы выбрать все вершины, вы можете отмасштабировать их с помощью "S". Вновь поместите курсор в 3D окно и нажмите "F" для выхода из режима выбора граней. Нажмите "P" для проигрывания игровой анимации, проверьте правильно ли легла текстура.

Дополнительные опции UV текстур находятся в панели [UV Calculation] (см. рисунок). Не бойтесь эксперементировать с ними!


Использование Physics Engine в анимации

Новинкой Blender'a версии 2.40 стал движек Bullet, предназначенный для создания IPO кривых анимации. Теперь вместо того, что бы вставлять ключевые кадры анимации падения/полета/прыжков в окне IPO или 3D окне, вы можете воспользоваться движок Bullet и настроить его таким образом, что действия объекта будут присвоены IPO кривым анимации. Теперь у Вас не будет затруднений с анимацией падения/полета/прыжков - Blender сделает все за вас! Для начала перейдите к кнопкам настройки Окружения и во вкладке Mist/Stars/Physics выберите тип движка Bullet.

Теперь вам необходимо создать актера. Для того, чтобы прыжки, движения и падения актера выглядели реалистично нажмите на кнопку "Rigid Body" в панели настройки актеров, а так же активизируйте кнопку Bounds. Нажмите "P" для просмотра игровой анимации.

Когда вам будет необходимо откорректировать анимацию, зайдите в меню "Game" и в выпадающем списке выберите опцию "Record Game Physics to IOP".

Нажмите кнопку "P" для запуска анимации. В финале ее нажмите кнопку "Esc". После этого анимация записалась в виде IPO кривых для объекта и теперь ее можно запускать с помощью "Alt-A" и обращаться как с обычной анимацией!


Практическое Занятие

Анимация Реального Времени

Создайте сцену как описывалось в Главе 20. Она должна содержать одного актера и плоскость, у обоих объектов должны быть текстуры. Добавьте актеру физические свойства - в игровой анимации он должен двигаться вперед, назад, влево и вправо. В финале преобразуйте игровую анимации в обычную (создайте IPO кривые) и создайте обычный анимационный клип.


Глава 21: Редактор Видео Последовательностей

Создание фильма из отдельных клипов

Все известные анимационные фильмы не создавались как одна непрерывная анимация. Анимационные фильмы состоят из коротких клипов и изображений, в сочетании с звуковыми и др. эффектами. В Blender позволяет сделать большую часть из описанного. ОН может комбинировать видео клипы, а так же он поддерживает аудио. Однако, в данный момент Blender не может совмещать аудио и видео дорожки вместе. Это то, чего я лично жду в течение нескольких лет. Blender уже настолько близко подошел к тому, чтобы обеспечить все нужды аниматора, но к сожалению в нем отсутствуют функции основные функции редактирования аудио/видео компиляции, до сих пор большинство наших анимаций собираются в Adobe Premiere. Я очень надеюсь, что разработчики возьмутся за этот проект в будущем.

Настройки Редактора Последовательности

Экран Blender можно преобразовать в экран Редактора Последовательности. Чтобы сделать это , перейдите к верхней панели и выберите опцию "4-Sequence" (см. рисунок).

После того как вы это сделаете ваш экран Blender'a должен выглядеть приблизительно так:

Если Вы знакомы с такими программами как Premiere этот интерфейс может показаться вам знакомым, если нет,все очень просто. Первое что необходимо - это настроить в кнопках рендера формат вывода (тот формат видео который вы хотите в итоге получить). Нажмите кнопку "Do Sequence"("Сделать Последовательность"), что бы сделать последовательность видео и/или изображений.

Далее нажмите кнопку "Add", расположенную выше кнопок окна. Нас интересуют опции Effect (Эффекты промежутков), Audio (Аудио), Images (Изображения) и Movie (Фильмы). Выберите Movie или Images и добавьте в график времени(timeline) свой файл видео либо изображение.

Обратите особое внимание на маркеры в концах файла, который Вы вставляете. Изображение можно удлинить или сократить, кликните Правой Клавишей Мышки по маркерам в коцах, и нажмите кнопку "G", что бы переместить их. Фильмы можно только сократить.

Если вы хотели бы добавить Эффект перехода между двумя файлами (как правило накладывание), вы должны расположить их как показано на рисунке ниже (растояние между двумя файлами 1 или 2 секунды). Я Предпочитаю оставлять промежуток между файлами (как показано ниже) для того, что бы вставить эффект перехода позже.

Продолжайте добавлять изображение и/или видео клипы если это необходимо. После того как вы закончите добавлять клипы или изображения необходимо вставить Эффекты перехода, удерживая кнопку "Shift" выберите первый файл последовательности, затем второй. Если выбрать их в обратном порядке это может сильно повлиять на Эффект перехода! Зайдите в меню "Add" и выберите опцию "Effect", а затем выберите эффект перехода, который вы хотите использовать. Эффект "Cross" обычно хорошо работает в большинстве случаев. Расположите Эффект между файлами.

Для просмотра образца анимации, поместите свой курсор в окошко предварительного просмотра и нажмите "Atl-A". Вставьте эффекты перехода для остальных загруженных вами файлов. Если вы не хотите использовать эффект промежутков, а просто хотите сделать обычные переходы от одного изображения к другому - просто расположите файлы один за другим и не добавляйте эффектов.

Для создания конечной анимации кликните Правой Клавишей Мышки по последнему изображению в анимации, для того что бы определить последний кадр. Введите это значение в поле End в панели рендера Anim. Нажмите на кнопку "Anim" для начала сборки анимации. Воспроизведение будет быстрее, поскольку вы только компилируете уже созданные изображения.


Добавление Аудио Дорожки

Добавить звуковую дорожку сложно тем же способом, что и видео клипы или изображения. Учтите, что некоторые звуковые форматы не поддерживаются, и вам придется поэкспериментировать с ними. Аудио форматы Wave (.Wav) поддерживаются лучше всего. Для того, что бы экспортировать Аудио дорожку, перейдите к кнопкам Звука (см. рисунок) и нажмите кнопку "MIXDOWN". Аудио дорожка будет иметь такое же названия как и фильм, который вы делаете. После этого вам необходимо собрать звук и фильм в другой программе.


назад Основы Blender v.2.42a

Практическое Занятие

Создание Фильма

Это самое большое Практическое Занятие является заключительной частью этой книги. Ваша задача - из всех изображений и анимаций, которые вы сделали, выполняя практические занятия этого учебника, собрать полноценный фильм. Я рекомендую создать черное JPEG изображение для начала и окончания фильма (фильм будет начинаться и заканчиваться черным изображением). Изображения должны отображаться приблизительно 3-5 секунд с 1 секундным переходом.

Совет
Лучше подобрать изображения и анимации, которые имеют одинаковый размер одинаковое количество кадров в секунду(относится к анимации). Иначе могут произойти некоторые проблемы с форматированием, когда Blender попытается объединить отличные по размеру fps изображения и анимации

Я надеюсь этот мануал будет полезен вам в изучении этой сложной, но все же мощной программы.

назад | Основы Blender v.2.42a
назад | Оглавление